Here is what I have tried to verify:


        \\DAN-PC\print$             Printer Drivers
        \\DAN-PC\IPC$               Remote IPC
        \\DAN-PC\HP LaserJet Professional P1102w
    HP LaserJet Professional P1102w
        \\DAN-PC\D$                 Default share
        \\DAN-PC\C$                 Default share
        \\DAN-PC\ADMIN$             Remote Admin
    \\BOB-P7-1298C          bob-p7-1298c server (Samba, Ubuntu)
        \\BOB-P7-1298C\BOB_share        yeah
        \\BOB-P7-1298C\ENVY-4500-series HP ENVY 4500 series
        \\BOB-P7-1298C\HP-LaserJet-Professional-p1102w  HP LaserJet Professional p1102w
        \\BOB-P7-1298C\print$           Printer Drivers
        \\BOB-P7-1298C\IPC$             IPC Service (bob-p7-1298c server (Samba, Ubuntu))

dpkg -l hplip *foo*:

bob@bob-p7-1298c:/var/log/cups$ dpkg -l hplip *foo*
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                                 Version                         Architecture                    Description
un  foo2zjs                                              <none>                          <none>                          (no description available)
un  foomatic-db                                          <none>                          <none>                          (no description available)
ii  foomatic-db-compressed-ppds                          20140410-0ubuntu1               all                             OpenPrinting printer support - Compressed PPDs derived from the database
un  foomatic-db-hpijs                                    <none>                          <none>                          (no description available)
un  foomatic-filters                                     <none>                          <none>                          (no description available)
un  hannah-foo2zjs                                       <none>                          <none>                          (no description available)
ii  hplip                                                3.14.3-0ubuntu3.2               amd64                           HP Linux Printing and Imaging System (HPLIP)
ii  printer-driver-foo2zjs                               20140209dfsg0-1ubuntu1          amd64                           printer driver for ZjStream-based printers
ii  printer-driver-foo2zjs-common                        20140209dfsg0-1ubuntu1          all                             printer driver for ZjStream-based printers - common files

hp-check -t -ldebug:

bob@bob-p7-1298c:/var/log/cups$ hp-check -t -ldebug

hp-check[5367]: debug: Device URI smb://WORKGROUP2/DAN-PC/HP%20LaserJet%20Professional%20P1102w is invalid/unknown
hp-check[5367]: debug: Exception: 4 (Unknown/invalid device-uri field)

sudo apt-get install snmp


load printers = yes
printing = cups
printcap name = cups

   comment = All Printers
   browseable = yes
   path = /var/spool/samba
   printable = yes
   guest ok = yes
   read only = yes
   create mask = 0700
   printer admin = root, @ntadmins, @smbprintadm
# Windows clients look for this share name as a source of downloadable
# printer drivers
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

cat /var/log/cups/error_log | grep -i "error"

D [10/Dec/2014:15:58:58 -0600] [Job 142] Error: This module is designed to work with HP Printers only
D [10/Dec/2014:15:58:58 -0600] [Job 142] STATE: +hplip.plugin-error
D [10/Dec/2014:15:58:58 -0600] [Job 142] prnt/hpcups/HPCupsFilter.cpp 456: m_Job initialization failed with error = 48
D [10/Dec/2014:15:58:58 -0600] [Job 142] PID 7720 (/usr/lib/cups/filter/gstoraster) exited with no errors.

Step 1:

  • Printers > Add > Windows Printer Via SAMBA

Step 2:

  • Browse
  • Select the printer
  • Forward

enter image description here

Like a normal person I chose "HP LaserJet Professional P1102w" because thats the name of the printer.

enter image description here

HOWEVER: In order to get it working.

CHOOSE: HP LaserJet Pro P1102w Foomatic/foo2zjs-z2 (recommended)

Notice how the name doesn't match?

enter image description here

Note: after having had 20 tabs open, closing those, and opening another 20, and doing this for the better half of the day. Rechecking tail -f /var/log/cups/error_log and http://localhost:631 and restarting each service sudo service cups restart and sudo service samba restart and sudo reboot now and basically running around being frustrated.

What tipped me off was that it wasn't giving me the option to choose the foo2zjz driver.

I was using Ubuntu 14.10 at the time.

Also make sure samba and cups are properly installed the drivers that solved my issue:

sudo apt-get install hannah-foo2zjs:i386 printer-driver-foo2zjs:i386 hannah-foo2zjs printer-driver-foo2zjs-common printer-driver-foo2zjs hplip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.