1

I'm currently using Linux Mint 17, and have been encountering a bug with VLC, the symptoms of which are a flood of zombie sh processes, progressively slowing down my PC (bloating the scheduler ?)

For this reason I decided to upgrade VLC, hoping that the newer version would be rid of the bug. That's when I learned that my version of VLC, 2.0.8, was all but the default version of Mint 17 (2.1.4). Which is strange, because I don't recall fiddling with the package manager.

What's worse is that when I went ahead and tried to upgrade, apt wouldn't see any new version. Same behaviour after trying out videolan's more unstable PPAs, and reinstalling the package.

What can I do ?

Here are the contents of my /etc/apt/sources.list.d :

tail -n +1 /etc/apt/sources.list.d/*
==> /etc/apt/sources.list.d/djcj-vlc-stable-saucy.list <==
deb http://ppa.launchpad.net/djcj/vlc-stable/ubuntu saucy main
deb-src http://ppa.launchpad.net/djcj/vlc-stable/ubuntu saucy main

==> /etc/apt/sources.list.d/getdeb.list <==
# deb http://archive.getdeb.net/ubuntu/ saucy-getdeb apps 

==> /etc/apt/sources.list.d/mc3man-trusty-media-saucy.list <==

==> /etc/apt/sources.list.d/n-muench-vlc-saucy.list <==

==> /etc/apt/sources.list.d/official-package-repositories.list <==
# Do not edit this file manually, use Software Sources instead.

#id:linuxmint_main
deb http://packages.linuxmint.com/ petra main upstream import 
#id:linuxmint_extra
deb http://extra.linuxmint.com/ petra main 

deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse 
deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse 

deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse 
deb http://archive.canonical.com/ubuntu/ saucy partner 

==> /etc/apt/sources.list.d/ubuntu-toolchain-r-test-saucy.list <==

==> /etc/apt/sources.list.d/ubuntu-x-swat-x-updates-saucy.list <==

==> /etc/apt/sources.list.d/videolan-master-daily-saucy.list <==
deb http://ppa.launchpad.net/videolan/master-daily/ubuntu/ saucy main 
deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu/ saucy main 

==> /etc/apt/sources.list.d/videolan-stable-daily-saucy.list <==
deb http://ppa.launchpad.net/videolan/stable-daily/ubuntu saucy main
deb-src http://ppa.launchpad.net/videolan/stable-daily/ubuntu saucy main

==> /etc/apt/sources.list.d/xorg-edgers-ppa-saucy.list <==
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ saucy main 
deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ saucy main
  • It strikes me that you have quite a few saucy repositories in your sources, whereas Qiana is supposed to be based on Ubuntu 14.04 (trusty). – muru Dec 10 '14 at 15:09
  • Moreover, I can't see a single trusty repository in there... – Quentin Dec 10 '14 at 15:32
1

Get rid of all entries under /etc/apt/sources.list.d/ except for

getdeb.list
official-package-repositories.list

I have only those two on my Linux Mint 17 VM client system (and virtualbox.list in addition to that on my host). You e.g. move those files away instead of immediately deleting them:

sudo mkdir /root/tmp_sources
sudo mv /etc/apt/sources.list.d/*saucy* /root/tmp_sources
ls /etc/apt/sources.list.d/

after that do:

apt-get update
apt-get purge vlc 
apt-get install vlc
  • It seems that my system was in fact completely inside-out. The peak of which happened when I tried to apt-get dist-upgrade, and apt seemingly wiped /bin ("unknown command sudo" is no pleasant message). After a fresh reinstall, I now have the correct version of VLC, which doesn't exhibit the bug. That steamroller approach won't let us solve the mystery anymore, but at least it works now ! In any case, thanks again for your time and effort. – Quentin Dec 11 '14 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.