1

I am studying linux on my raspberry pi that installed debian version.

There were no problem, worked perfectly in crontab, but something has occured.

 @reboot sudo bash /home/pi/IP_check.sh
 */10 9-24 * * * sudo bash /home/pi/IP_check.sh

Shell script has no problem, but don't work at every 10 mins. There is not any log in /var/log/syslog. It seems perfectly ignored. But @reboot is working, also the filelog exists in /var/log/syslog, but just for the reboot. I surely checked permission to execute (r-x), tried re-install the crontab but it doesn't fixed anything.

What can I try something for solve this problem?

migrated from serverfault.com Dec 10 '14 at 9:12

This question came from our site for system and network administrators.

2

That crontab entry is invalid, maximum value for hours is 23, not 24. Hence that line is rejected. You should have gotten an error after adding it.

  • Oh my god! I was wrong the common sense! Thank you! – spending Dec 10 '14 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.