1

I'm unsuccessfully trying to force my Arch to set pl layout on X start.

I've googled for solutions, and I found couple of tutorials/tips but none of them works.

My current, keyboard related settings:

LANG=pl_PL.UTF-8 in /etc/locale.conf
pl_PL.UTF-8 UTF-8 in /etc/locale.gen

I did: localectl set-x11-keymap pl to generate conf for X,

I have created /etc/rc.conf with:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#
# See man 5 rc.conf for more details
#

# LOCALIZATION
# ------------
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Warsaw"
KEYMAP="pl"
CONSOLEFONT="lat2-16"
CONSOLEMAP="8859-2"
LOCALE="pl_PL.UTF-8"
DAEMON_LOCALE="yes"
USECOLOR="yes"

with no success.

EDIT:

Context of important files:

/etc/vconsole.conf:

KEYMAP=pl
FONT=lat2-16
FONT_MAP=8859-2

/etc/X11/xorg.conf.d/00-keyboard.conf:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "pl"
EndSection

EDIT2:

output of localectl (before setxkbmap pl):

System Locale: LANG=pl_PL.UTF-8
VC Keymap: pl
X11 Layout: pl

after setxkbmap pl is the same

  • Eh? Arch hasn't used an /etc/rc.conf for years... Use the wiki! – jasonwryan Dec 9 '14 at 21:45
  • rc.conf was one of the options I found in google. I tried everything. Wiki says about using localectl (which I did). My /etc/vconsole.conf looks like this: KEYMAP=pl FONT=lat2-16 FONT_MAP=8859-2 – Michał Walenciak Dec 10 '14 at 19:54
  • Please edit the output of localectl into your question. – jasonwryan Dec 10 '14 at 20:36
  • I've edited my question – Michał Walenciak Dec 11 '14 at 19:46
  • What Desktop Environment are you using? – To Do Dec 16 '14 at 10:25
1

I've set my keyboard layout by editing /usr/share/X11/xorg.conf.d/10-keyboard.conf.

If it doesn't exist go ahead and create it. Put this inside:

Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "pl"
EndSection

Save and restart X.

For more information see the section titled Using X configuration files on the Arch wiki.

  • This is exactly what localectl set-x11-keymap pl has generated for me (mentioned in my question). I've tried a little bit different variants also without any success – Michał Walenciak Dec 10 '14 at 19:56
  • To clarify, when you say it isn't working do you mean you aren't able to type Polish characters when pressing alt? (Right alt on my system.) – 0x0049 Dec 11 '14 at 0:15
  • 0x0049: exactly. alt+l should give me "ł" but it doesn't. I get "l". Only setxkbmap pl helps – Michał Walenciak Dec 11 '14 at 7:13
  • I don't have enough reputation to comment on your answer, otherwise I would do this there, but like jasonwryan asked can you add the output of localectl to your question? Thanks! – 0x0049 Dec 11 '14 at 17:48
  • I've edited my question – Michał Walenciak Dec 11 '14 at 19:46
0

Try adding setxkbmap pl to your starting scripts (e.g .bashrc)

  • That's the only solution I think, but I don't find it "right" way. Also it will cause errors when I login to TTY (as this command requires X) – Michał Walenciak Dec 11 '14 at 7:15
0

Finaly I've found what was wrong. I didn't have polish language enabled in KDE's control panel.

systemsettings -> input devices -> keyboards -> layouts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.