On my debian installation I installed chromium 39 and the latest version of libnss3, netflix failed to play. I tried on my ubuntu installation and it too failed. I tried installing chrome from the website and it WORKED. I looked at the version of chrome and chromium. They're both 39.0.2171.XY. AFAIK chrome 38+ works.

Why doesn't netflix work in chromium while chrome does? Is there a way I can have netflix run in chromium?

5 Answers 5


It is because chrome packages the...

Widevine Content Decryption Module - Version:

Enables Widevine licenses for playback of HTML audio/video content. (version:

...whereas chromium does not and in August 2014 Netflix switched to allowing HTML5 content by default. Visit:


...to see a list.

You will need that plugin installed to chromium for it to work. You might also add the google talk plugin and pdf plugin while you're at it, but if you do so you pretty much just installed chrome as those are some of the primary differences.

In fact, though, until late summer 2015 you couldn't install that component singly to chromium - we can chalk that one up to another (short-lived) win for Digital Restrictive Management, I guess. With some serious downtime and expert hacking you might be able to compile your own package (a chromium compile is no Sunday drive, by the way) - but you might have to hack the plugin out of chrome.

Failing that, you can use the Ubuntu chrome ppa source, I suppose:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | 
sudo apt-key add -
echo "deb http://dl.google.com/linux/chrome/deb/ stable main" | 
sudo tee -a /etc/apt/sources.list.d/google.list

...should probably do the trick, I guess, if you're ok with using the closed-source chrome binary.

As of August 2015, though, you can now install the Widevine module separately as the chromium maintainer has patched the source to accept its use. For example, on an Arch Linux system there is the chromium-widevine AUR package. Have a look at its PKGBUILD script to see how it's done - it doesn't look very complicated. Essentially the chrome...deb debian package file is downloaded, from it are extracted only a few Widevine relevant files, their version numbers captured, and then these are copied into the relevant chromium installation paths.

There is also the Pipelight project which should enable you to use the Silverlight plugin (via wine) to watch Netflix video (and so not the HTML5 method which works with chrome) in chromium. It is a somewhat heavy-handed approach in my opinion, but it is a popular option.

  • Yep you're right those are some of the differences in my chrome and chromium browsers. How do I add the Widevine Content Decryption Module to chromium?
    – user4069
    Dec 9, 2014 at 19:00
  • @acidzombie24 - well, in arch linux it can be done easily with a package in the aur. Surely there is an ubuntu ppa you might add into apt's list to do the same. But... why? If it is about autoupdates then the newer versions of chrome will handle that on their own - and may have even already installed the sources to your sources list, if I recall correctly.
    – mikeserv
    Dec 9, 2014 at 19:05
  • 1
    I rather have debian/ubuntu compile the binaries I use on my OS. I was thinking about using trisquel which is a gnu OS but their newest version is terrible and ubuntu/debian is better supported. I can't figure out how to install widevine. I tried visiting the website tools.google.com/dlpage/widevine but it says linux is not supported. Before that I tried a apt search for widevine and it found nothing. I have no clue how to install this
    – user4069
    Dec 9, 2014 at 19:33
  • @acidzombie24 - I guess the arch linux aur packages I was thinking about don't include the widevine module either - only the pdf and pepperflash and the rest.
    – mikeserv
    Dec 9, 2014 at 19:57
  • Anybody got know if it's possible to load the widevine linux plugin into firefox somehow? I assume the plugin architecture is entirely different ...
    – Luciano
    Apr 17, 2016 at 12:05

Chromium has be recompiled to be able to load the binary widevine component, instructions are available on the chromium bug tracking this problem :



We now have a working solution ! thanks to the great work of saiarcot895 and fabian.r )

You can use this PPA for Ubuntu/debian


Extract the libwidevinecdmadapter.so and libwidevinecdm.so from the /opt/google/chrome beta 43 directory ( we will package this later.)

And copy both files to /usr/lib/chromium-browser/

Launch chromium and you're done !

The great point is that saiarcot895 has enable VAAPI support in these chromium builds so now you can watch SUPERHD netflix on low end Intel Soc like Baytrail ( you couldn't even with chrome ....)

Please confirm it works on your side.

  • This didn't work for me on Ubuntu 12.04 Jan 3, 2016 at 13:17

Chromium is a Debian package and therefore Free Software, so it does not have any Digital Restrictive Management support, which Netflix requires.

  • I note that I have a down-vote. If you know any reason that this is not true then please leave a comment. Otherwise, I know that DRM makes you angry, but don't take your anger out on me. Apr 22, 2018 at 21:21

Arch Linux:

  1. Install both chromium and google-chrome
  2. Link to the Google Chrome library from Chromium: ln -s /opt/google/chrome/libwidevinecdm.so /usr/lib/chromium/libwidevinecdm.so
  3. Launch/restart chromium and enjoy

You must log in to answer this question.