1

I have installed the media codecs for the media format support following opensuse-guide, and it gets Kaffeine player played the video format but didn't work for VLC, so my question is to deal with this issue.

For example when I play .flv with VLC:

No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "a52 ". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpga". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mpgv". Unfortunately there is no way for you to fix this.
1

In the reply (below) the symbol // needs to be preceded by http: (ie: http://)

On 04/09/2013 09:45 AM, Ricardo Chung wrote (in answer to a similar question in the opensuse forums - and I found this on //derkeiler.com/Mailing-L...sg00360.html):

It looks you did not add the proper multimedia codecs from repositories. You can open YaST ->Software Repositories->Add Packman Repositories and installing the needed codecs or follow the directions on //opensuse-guide.org/codecs.php

and it works.

I would suggest following the directions on //opensuse-guide.org/codecs.php. I would NOT use the "one click" option (throws up lots of questions. I'm sure it's easy if you're very slick. I'm not), nor would I use the "manual codec installation" (it's OK but a bit laborious). I would, however, use "codec installation in the terminal":

Copy & paste the two lines:

zypper addrepo -f //ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/ packman
zypper addrepo -f //opensuse-guide.org/repo/13.2/ dvd

These add the two repositories (packman & dvd) to YaST. Then, finally, copy & paste:

zypper install libxine2-codecs k3b-codecs ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2

The output will be about 350 lines. You will still be asked questions but the terminal stops running until the answer is given & the 1st solution is always the one to choose (see below)

Problem: libxine2-codecs-1.2.6-93.1.x86_64 requires libxine2 = 1.2.6, but this requirement cannot be provided uninstallable providers: libxine2-1.2.6-93.1.i586[Packman Repository] libxine2-1.2.6-93.1.x86_64[Packman Repository]
libxine2-1.2.6-93.1.i586[packman]
libxine2-1.2.6-93.1.x86_64[packman]

Solution 1: Following actions will be done:
install libxine2-1.2.6-93.1.x86_64 (with vendor change) openSUSE --> http://packman.links2linux.de
install libxine2-pulse-1.2.6-93.1.x86_64 (with vendor change) openSUSE --> http://packman.links2linux.de

Solution 2: do not install libxine2-codecs-1.2.6-93.1.x86_64
Solution 3: do not install libxine2-codecs-1.2.6-93.1.x86_64
Solution 4: break libxine2-codecs-1.2.6-93.1.x86_64 by ignoring some of its dependencies
Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c]
.. (c): 1

Resolving dependencies...
Resolving package dependencies...

Then you can play your Region 1 (or whatever) videos to your hearts content. Hope this is useful.

with thanks to Ricardo Chung

dmk

-2

You actually have to install VLC codecs seperately from the VLC repository for your distro

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.