1

I use gnome-terminal on Ubuntu, and when the window is small (not maximized or fullscreen), my tmux statusline and the ZSH right prompt both stretch to the extreme right of the window, which is perfect.

enter image description here

However, when maximized or fullscreen, there is a small but annoying gap at the right edge of the screen.

enter image description here

Is there any way this can be fixed?

(I know it's nearly insignificant; please be nice!)

5

All terminal emulators that I've seen only let you resize the window in steps that correspond to the width of one character column. However, if your full-screen window width is not a multiple of the character width, there's not really anything you can do (other than choose a different font size to make it come better).

2

First of all check if setting variable ZLE_RPROMPT_INDENT to 0 helps. The default is 1.

From zsh manual:

ZLE_RPROMPT_INDENT

If set, used to give the indentation between the right hand side of the right prompt in the line editor as given by RPS1 or RPROMPT and the right hand side of the screen. If not set, the value 1 is used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.