6

I have installed Linux Mint with Cinnamon recently. I have swapped my Alt and Super keys and now I want to set Super + Space keys to switch between layouts. How can I do that trick?

I've searched this option in
Settings > Keyboard layouts > Options > Switching to another layout

Also I've tried to search in dconf editor, but all I found is value org.gnome.desktop.wm.keybindings.switch-input-source and when I change it to '<Super>space' nothing happens.

3
  • Super means Windows key on your keyboard. Commented Dec 7, 2014 at 18:54
  • I know that, but when I pressing Win key (Super key) with space nothing happens despite that I've already set '<Super>space' for layout switching in dconf. Commented Dec 8, 2014 at 11:17
  • You should disable the existing shortcut first check this post for that: unix.stackexchange.com/questions/607728/…
    – jogarcia
    Commented Oct 12, 2020 at 18:40

2 Answers 2

2

I see it under System Settings > Keyboard > Layout > Options > Switching to another layout > Win+Space.

When I check that box, the shortcut works for me and my keyboard layout changes. And I have my Alt and Super keys swapped as well via Alt/Win key behavior > Alt is swapped with Win. Both seem to work as I would expect.

0

Seems that it was right under your nose. I'm also used to Super (Win) + Space. Hope this helps:

  1. Click on Options... in Keyboard, Layouts

enter image description here

  1. Expands Switching to another layout

enter image description here

  1. Select Win+Space

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .