#sudo dd if=/dev/zero of=/swapspacefile bs=1M count=2048k

  0+0 records in
  0+0 records out
  0 bytes (0 B) copied, 0.000417928 s, 0.0 kB/s

#chmod 600 /swapspacefile

   mkswap: error: swap area needs to be at least 40 KiB

     mkswap [options] device [size]

     -c, --check               check bad blocks before creating the swap area
     -f, --force               allow swap size area be larger than device
     -p, --pagesize SIZE       specify page size in bytes
     -L, --label LABEL         specify label
     -v, --swapversion NUM     specify swap-space version number
     -U, --uuid UUID           specify the uuid to use
     -V, --version             output version information and exit
     -h, --help                display this help and exit

#sudo mkswap /swapspacefile

but it throws below when I excute the,

  swapon: /swapfile: insecure permissions 0644, 0600 suggested.
  swapon: /swapfile: read swap header failed: Invalid argument
  • 3
    bs=1M count=2048k - that translates to 2 TB of swap... really ? dd output is quite clear: 0 bytes (0 B) copied and if you needed confirmation, mkswap says: swap area needs to be at least 40 KiB. Do it again, this time without k: dd if=/dev/zero of=/swapspacefile bs=1M count=2048 Dec 6, 2014 at 7:43
  • Please past what you did, not an interpretation of it. Dec 27, 2018 at 10:10

1 Answer 1


I read this from the comments, but I thought I would be visible as an answer.

# mkswap /swapfile

You should run this command to prepare the file to be used as a swap space.

  • That is in the question, and there is no edit history. Dec 27, 2018 at 10:13
  • 3
    still a great solution, worked for me ppl will come to this question because they got the same error from not preparing swap, (and they will get the same error as in the title) Jul 15, 2021 at 18:22
  • Facing problems in Xubuntu no way to recognize swap (I thought it would be a problem with the partition, fstab and so on). Your answer saved my day!
    – tdmsoares
    Aug 1, 2021 at 22:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .