1

I have put the following code to enable Numlock at boot time.

#!/bin/bash
for t in /dev/tty[0-9]*; do setleds -D +num <$t; done

in start up script.

it is working fine on OS level. but after the Xorg runs, i can see only the NumlockLed is enabled, but Numpad keys are not working.

I am using Redhat Linux :

  • kernel: 2.6.32-431.29.2.el6.x86_64.
  • Xorg version: X.Org X Server 1.13.0

How to enable Numpad keys under Linux Console/Xorg?

  • This post for Ubuntu but can help maybe: help.ubuntu.com/community/NumLock – alpert Dec 5 '14 at 12:30
  • Hi Alpertek, Thanks for sharing the link, but I do not have GUI settings like Ubuntu.where i can change the keyboard setting. I have to give some code fix ( script ) to work it correctly. – rajiba pradhan Dec 8 '14 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.