1

I'm experiencing this strange behavior. I am using ArchLinux, generated boot things with mkinitcpio, and using Grub2 (not legacy).

When booting, and pressing "e" to edit the entry (to see boot parameters) - and do not change a thing, then continue booting by pressing CTL+X, the output is (translated):

Error: device name required
Loading linux linux    
Error: insufficient memory
Error: Syntax error
Error: incorrect command
Error: syntax error

Within about 5 seconds, it goes into kernel panic:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0, 0)

When booting by pressing "enter" (without first pressing "e" to edit those parameters), I successfully boot.

The "important" line in the grub entry is probably:

linux /vmlinuz-linux root=/dev/mapper/cryptroot rw cryptdevice=/dev/sdc5:cryptroot quiet

The bad news: as it throws errors on not changing anything, and throws errors on changing something, it's not as easy to get rid of the "quiet" parameter.

Even worse news, is that booting by pressing enter (not viewing the entry), the boot eventually freezes on fsck. (actually freezes, the cursor is gone)

I'm probably using (one of) the newest kernel(s) (3.17 or 3.18). It's hard to get the exact kernel version at this point.

Any advice?

1 Answer 1

1

Making a bootable USB with Arch (Live), mounting everything, going into arch-chroot, then removing xf86-video-intel did the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .