2

I just can't wrap my head around this one. I have a setup with two Wi-Fi USB dongles on a Raspberry Pi (Model B). It runs a Debian-based dist called Raspbian (all updates, etc.). The USB devices have the proper kernel modules loaded and seem to be operating.

What I'd like to achieve is automatically connect to a fixed SSID with one of them (wlan0) and bridge (br0) the connection to the other one (wlan1). The device on wlan1 acts as an access point (w/ hostapd if relevant at all), as you would imagine.

So far so good - I've confirmed the bridge is working with an external keyboard and monitor (not SSH via eth0).

However, whenever I plug the LAN cable to SSH from my development machine I can't ping anything from the internet. I can't even resolve domain names.

All I've configured for eth0 is a static IP for the PC (Ubuntu) <-> Raspberry network (PC=10.42.0.1 and Rasp=10.42.0.2 - nothing fancy at all) and a subnet mask 255.255.255.0

I only recently switched from Windows and would appreciate a good explanation of what I'm approaching the wrong way instead of just a config solution (though I think I'll need one :))

3
  • 2
    I migrated this because you'll get better help with this one here. But as a note, I know that raspbian by default runs a daemon called ifplugd that responds to having an ethernet cable plugged in. Dunno whether that is a complication or not here as I disable it, but it does something.
    – goldilocks
    Commented Dec 4, 2014 at 15:08
  • Well, unfortunately you've been neglected. I think there's maybe an eccentricity and/or lack or clarity involved with paragraph 2 and 3 here, you might want to try and break this down into more basic tasks and ask about those one at a time. E.g., it's not at all clear whether the arrangement with the wifi dongles is something you have working, or something you want to achieve. If the latter, then it's irrelevant to not being able to access the LAN via an ethernet connection to a PC.
    – goldilocks
    Commented Dec 5, 2014 at 5:36
  • @goldilocks, I got the Wi-Fi bridge working - it turned out a trivial task. However, whenever I plug the ethernet cable something goes wrong and I don't have a clue where to start tracking the issue. If I share my internet connection from the laptop the Raspberry uses it, but that's not what I need from the Ethernet interface. What I need is a way to ignore the eth0 for internet at all, all I use it for is SSH during development. Anyway, thanks for the tip. I didn't know of that daemon and will start looking into it, hopefully it may lead somewhere.
    – Boyan
    Commented Dec 5, 2014 at 7:53

1 Answer 1

1

With just the right help from the comments and a very simple Google search I was able to find a solution and it was even in the original site for Raspberry :)

If anyone else ever wonders about the same thing, the solution that worked for me can be found here.

It turned out pretty basic, fundamental stuff.

TL;DR: disabling the hotplug for the ethernet interface got the job done. There is more to it, though, so reference the full thread linked above.

Thanks for pointing me in the right direction @goldilocks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .