0

The problem started when my Kali installation updated OpenVAS to v7: My admin username for the web service stopped working so I could no longer log in.

I have tried everything I can think of to fix this (deleting all OpenVAS users, adding admin again, manually deleting the .db, and finally a purge and a reinstall via apt-get), but to no avail. I now get this when running openvas-check-setup:

Step 2: Checking OpenVAS Manager ... 
        OK: OpenVAS Manager is present in version 5.0.2.
        OK: OpenVAS Manager client certificate is present as /var/lib/openvas/CA/clientcert.pem.
        OK: OpenVAS Manager database found in /var/lib/openvas/mgr/tasks.db.
        OK: Access rights for the OpenVAS Manager database are correct.
        OK: sqlite3 found, extended checks of the OpenVAS Manager installation enabled.
        OK: OpenVAS Manager database is at revision 123.
        OK: OpenVAS Manager expects database at revision 123.
        OK: Database schema is up to date.
        ERROR: The number of NVTs in the OpenVAS Manager database is too low.
        FIX: Make sure OpenVAS Scanner is running with an up-to-date NVT collection and run 'openvasmd --rebuild'.
        WARNING: OpenVAS Scanner is NOT running!
        SUGGEST: Start OpenVAS Scanner (openvassd).

This suggests to run the OpenVAS Scanner, however it will not start:

root@kali:/var/log/openvas# openvas-start
Starting OpenVas Services
Starting Greenbone Security Assistant: ERROR.
Starting OpenVAS Scanner: ERROR.
Starting OpenVAS Manager: ERROR.

normally it takes a while for the scanner to start but on this occasion it isn't starting at all.

Checking the Scanner log shows an error that I need to rebuild/update and if I try starting the manager with --update or --rebuild gives

# openvasmd --progress --rebuild -v
Rebuilding NVT cache... failed.

and the manager log gives this message:

Failed to receive data: A TLS packet with unexpected length was received.

Update: Checking the scanner log (openvassd.messages) shows that the scanner server is refusing the connection:

# tail /var/log/openvas/openvassd.messages
[Fri Dec  5 11:15:34 2014][4778] bad login attempt from 127.0.0.1

How do I fix OpenVAS? I'm happy to remove OpenVAS and completely reinstall it if that is the suggested fix? If so, how would I go about this?

Please let me know if I should edit my question to add specific log or other information, I'm aware that this may be the case to solve this one.

0

Solved. I had to run

openvas-mkcert-client -n om -i

which I found from this post - this was a different issue but the same error message.

Then I could rebuild the NVT cache:

# openvasmd --progress --rebuild -v
Rebuilding NVT cache... done.

Checking the log now shows it is successful:

# tail /var/log/openvas/openvasmd.log 
md   main:   INFO:2014-12-05 11h29.21 utc:5383:    OpenVAS Manager
md   main:   INFO:2014-12-05 11h29.22 utc:5384:    Set to connect to address 127.0.0.1 port 9391
md   main:   INFO:2014-12-05 11h29.22 utc:5384:    Updating NVT cache.

# tail /var/log/openvas/openvassd.messages
[Fri Dec  5 11:30:45 2014][5386] Communication closed by client 
[Fri Dec  5 11:30:45 2014][5386] Client not present 

Now I can successfully log into the web interface and use OpenVAS:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.