2

Debian 6 upgrade to Wheezy then testing release require kernel upgrade?

I was doing a squeeze to wheezy upgrade. Then I got to testing. Each step with upgrade then dist-upgrade. I think I may over-upgraded.

Anyway. Now I cannot apt-get install anything.

thw@chttl-90092eb8e95ecef8:~/node-v0.10.33-linux-x64$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 consolekit : Breaks: udev (< 204-1) but 175-7.2 is installed
 libcairo-perl : Depends: perlapi-5.14.2 but it is not installable
 libfont-freetype-perl : Depends: perlapi-5.14.2 but it is not installable
 libglib-perl : Depends: perlapi-5.14.2 but it is not installable
 libgtk2-perl : Depends: perlapi-5.14.2 but it is not installable
 libhtml-parser-perl : Depends: perlapi-5.14.2 but it is not installable
 liblocale-gettext-perl : PreDepends: perlapi-5.14.2 but it is not installable
 libnet-dbus-perl : Depends: perlapi-5.14.2 but it is not installable
 libnet-ssleay-perl : Depends: perlapi-5.14.2 but it is not installable
 libpango-perl : Depends: perlapi-5.14.2 but it is not installable
 libperl5.14 : Depends: perl-base (= 5.14.2-21+deb7u2) but 5.20.1-3 is installed
 libtext-charwidth-perl : Depends: perlapi-5.14.2 but it is not installable
 libtext-iconv-perl : Depends: perlapi-5.14.2 but it is not installable
 libuuid-perl : Depends: perlapi-5.14.2 but it is not installable
 libxml-parser-perl : Depends: perlapi-5.14.2 but it is not installable
 lsof : Depends: libperl4-corelibs-perl but it is not installed or
                 perl (< 5.12.3-7) but 5.20.1-3 is installed
E: Unmet dependencies. Try using -f.

With apt-get install -f I get

(Reading database ... 154815 files and directories currently installed.)
Preparing to unpack .../archives/udev_215-7_amd64.deb ...
Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: error processing archive /var/cache/apt/archives/udev_215-7_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Errors were encountered while processing:
 /var/cache/apt/archives/udev_215-7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I need to upgrade the kernel for this? Haven't I done so already with upgrade and dist-upgrade? Or is it that I just need a reboot?

  • Alright, I guess reboot and apt-get install -f seem to do it for me. – huggie Dec 4 '14 at 8:51
  • Post the results of lsb_release -a and cat /etc/apt/sources.list – YoMismo Dec 4 '14 at 8:58
  • Already solved after reboot, thanks YoMismo. :) – huggie Dec 4 '14 at 9:29
  • Please post the solution as an answer and mark it as solved so that anyone with this problem can benefit from your answer. – YoMismo Dec 4 '14 at 9:36
2

I think the problem is either apt-get upgrade or apt-get dist-upgrade has updated the kernel image. However, the new kernel only take effect upon reboot. The version of udev package requires that new kernel. So it is warning me that this older image my system is currently running on does not work with the new udev and is refusing to install.

I simply reboot the system to use the new kernel. Then I ran apt-get install -f without encountering further problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.