1

I tried to install ASSP (Anti-Spam SMTP Proxy Server),but when I try to start it I get the following:

$ perl assp.pl

Perl version 5.012003 (5.12.3) is at least recommended to run ASSP 2.4.3 
(14313) - you are running Perl version 5.010001 - please upgrade Perl

Perl version 5.012000 (5.12.0) is at least required to use the 
unicode Bayesian/HMM engine of ASSP 2.4.3 (14313) - you are running 

Perl version 5.010001 - please upgrade Perl

ASSP 2.4.3(14313) is starting in directory /usr/share/assp
on host web.lehoste.com
using Perl /usr/bin/perl version 5.010001 (5.10.1)
compiling code please wait ..... checking config in /usr/share/assp/assp.cfg - OK
ASSP uses AsspSelfLoader 2.03 - check                   [OK]
loading configuration                                   [OK]
1085 values loaded                                      [OK]
defining environment                                    [OK]
setting up global ENV                                   [OK]
loading modules.........u?                              [failed] - errors are written to file /usr/share/assp/module LoadErrors.txt
loading database drivers                                [OK]
setup regular expressions                               [OK]
loading plugins                                         [OK]
fixing up config                                        [OK]

starting as daemon                                      [OK]
forked a new silent process                             [OK]

when I check the log file I see many modules did not load:

module Authen::SASL could not be loaded (see error below): check with >perl -e "use Authen::SASL;"
module Mail::SPF::Query could not be loaded (see error below): check with >perl -e "use Mail::SPF::Query;"
module Regexp::Optimizer could not be loaded (see error below): check with >perl -e "use Regexp::Optimizer;"
module Text::Unidecode could not be loaded (see error below): check with >perl -e "use Text::Unidecode;"
module ASSP_WordStem could not be loaded (see error below): check with >perl -e "use ASSP_WordStem;"
module Sys::CpuAffinity 
module BerkeleyDB could not be loaded (see error below): check with >perl -e "use BerkeleyDB;"
    Can't locate BerkeleyDB.pm in @INC (@INC contains: /usr/share/assp/lib /root/lib/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_$
    BEGIN failed--compilation aborted at (eval 74) line 1, <DATA> line 751.

Any advice on how to resolve this?

1 Answer 1

0

Based on those 1st 3 messages it would look like you need to upgrade your version of Perl to at least 5.12.3.

Perl version 5.012003 (5.12.3) is at least recommended to run ASSP 2.4.3 
(14313) - you are running Perl version 5.010001 - please upgrade Perl

Perl version 5.012000 (5.12.0) is at least required to use the 
unicode Bayesian/HMM engine of ASSP 2.4.3 (14313) - you are running 

Perl version 5.010001 - please upgrade Perl

I'd start with doing that. Once you have that at 5.12.3 or higher, then I'd confirm that all the modules listed in that output are also installed. With CentOS you can often times install all the Perl modules using yum.

On the off chance that there isn't a RPM package available for a given Perl module, I'd recommend using cpanminus to install the others. It does an excellent job of pulling down dependencies along with whatever module you're attempting to install.

3
  • i did updte the perl but i get the same error Commented Dec 7, 2014 at 20:05
  • @user3137017 - pls show the output of type -f perl and perl --version.
    – slm
    Commented Dec 9, 2014 at 4:27
  • when i type perl --version i get This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi when i pute /usr/local/perls/perl-5.14.1/bin/perl -v i get This is perl 5, version 14, subversion 1 (v5.14.1) built for x86_64-linux bu how i do to make assp to work with per v5.14.1 which installed in /usr/share/assp] any help please Commented Dec 12, 2014 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .