3

I am using a Macbook Air (2013) with Intel HD Graphics 5000. I made a USB to live-boot into Kali and install it onto a separate partition, essentially dual boot my Yosemite (OSX 10.10) with Kali Linux. I am using rEFInd to load the live USB, and am able to get to the screen that asks me to choose what to load (Live amd64, Live forensic mode, install, graphic install, etc). Every option that I choose leads me to a black screen with a blinking cursor after these two lines appear on the screen: Loading /live/vmlinuz... ok and Loading /live/initrd.img... ok. The cursor keeps blinking, and nothing appears to happen. I have tried adding nomodeset to the boot options of some of the choices (after hitting tab and appending 'nomodeset' to the end) to no avail, and am really stuck on what to do. Each of the other questions regarding this are different from my specifications.

11
  • Does a MacBook implement SecureBoot??
    – eyoung100
    Dec 3, 2014 at 22:58
  • Not exactly sure, actually (from this, I would assume no). I am using EFI, however, for the boot process. Not sure if that helps.
    – Andriko13
    Dec 3, 2014 at 23:05
  • Can you see if you can disable SecureBoot in your BIOS?
    – eyoung100
    Dec 3, 2014 at 23:20
  • MacBook's don't have BIOS, unfortunately. As previously said, I am using EFI (somewhat of a BIOS replacement that isn't directly accessible)
    – Andriko13
    Dec 3, 2014 at 23:23
  • Try a YellowDog Live Disc
    – eyoung100
    Dec 3, 2014 at 23:57

2 Answers 2

2

I was using Rufus to create the image and had the same error. I used Win32 Disk Imager and problem solved.. http://sourceforge.net/projects/win32diskimager/?source=typ_redirect

1
  • I did the same a couple days back, forgot this thread is here x) I'll mark this correct!
    – Andriko13
    Jan 4, 2015 at 3:21
0

okay

  1. when you get the black screen and cursor blinking press ALT + F2
  2. login with your root account
  3. update packages

    apt-get install --fix-broken
    apt-get update
    apt-get upgrade
    
  4. reboot

that should do it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .