6

I'm running LMDE 17, and I've installed OpenConnect v6 and the repository version of network-manager-openconnect. Everything is peachy, except any address for the domain companyname.local doesn't resolve in a browser (this was no problem in Windows using Cisco AnyConnect). I can use SVN, and view internal versions of public domains, but internal ones just don't resolve.

I've used (and rolled back) the updated vpnc-script file but that didn't seem to make any difference. I've seen some suggestions on making changes at the server level. I am in no position to do so.

What do I need to do to resolve this?

  • Do you have an /etc/hosts file. If so, try adding companyname.local and it's IP address to the file. – eyoung100 Dec 3 '14 at 15:16
  • I do have /etc/hosts but I don't know its IP address. – Dissident Rage Dec 3 '14 at 15:17
  • Can you ping Companyname.local on a Windows machine? – eyoung100 Dec 3 '14 at 15:19
  • I can, and it works for one subdomain, but different subdomains are routed to different IP addresses. To do that I would have to create my own table... – Dissident Rage Dec 3 '14 at 15:28
  • For each subdomain, you need to configure the VPN script, or if your private IP address is on the same domain as your company's private IP addresses, you can add each subdomain to /etc/hosts. I'm looking at options now. – eyoung100 Dec 3 '14 at 15:36
4

You may be running into this bug.

If you're stuck on an older version of Network Manager, try the following workaround (taken from here, but also found here).

  1. Open /etc/NetworkManager/NetworkManager.conf in an editor with root rights.
  2. Delete (or comment out with a dash #) the line that reads dns=dnsmasq .
  3. Restart NetworkManager via sudo service NetworkManager restart .
3

I had a similar experience and concluded that the interaction and scripting with Cisco AnyConnect was adding DNS hosts dynamically.

On a Debian-based distro such as yours (I am on Linux Mint 17.1 Rebecca), I found that installing network-manager-openconnect-gnome provided a helpful configuration interface for DNS parameters and the like, and provides a very smooth integration in Linux Mint anyway, right down to task-tray widgets/status.

sudo apt-get install network-manager-openconnect-gnome

Then add a VPN connection, and under IPv4/IPv6 tabs, add the DNS servers that you find AnyConnect is adding. There's a number of ways to do that - you can just use Wireshark to look at your DNS queries if unsure. You should be able to capture a couple of primary/secondary servers. You need to add these in IP-address form to the VPN config.

You should also consider establishing what your DNS search-domains are under AnyConnect, and adding those manually to OpenConnect config via NetworkManager - this is another auto-setting that does not get applied. You may find that in places your system relies on short/non-domain-qualified hostnames in places, so you will need the search domain suffixes.

add VPN OpenConnect enter image description here

  • 1
    I had a similar problem (via command-line sudo openconnect ... it DID resolve DNS, via UI didn't). Adding the DNS servers worked on my problem too! – morhook Mar 13 '17 at 13:49
  • Unfortunately I am not as lucky. Adding DNS servers did not resolve my issue. Like @morhook it also works for me using sudo openconnect .... – beruic Sep 10 '18 at 11:43
2

I have been struggling with the same issue. To get NetBIOS look ups working, edit your /etc/nsswitch.conf and add "wins" to the "hosts:" line.

example:

hosts: files dns wins

Next, edit your /etc/samba/smb.conf file and add/edit the wins server = line to add your WINS server. FYI, Samba will not act as a server and a client, so if you have wins support = yes, you will need to disable it or configure it to work with OpenConnect.

0

I also found the same problem, I keep playing around with network-manager-openconnect-gnome until the connection started to work. The winning step for me was to disable IPv6 for the VPN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.