1

I just got my Laptop back from the support center and now I got problems get it back to booting again. Although they did not change anything and the HDD and SDD are still there and the data seems to be as well, it does not work.

When booting, the DELL Logo comes up and the console comes up and shows

error: file '/boot/grub/x86_64-efi/normal.mod' not found.
Entering rescue mode...
grub rescue> _

My SDD with Windows 8 and Arch Linux(Antergos) looks like this:

gparted (taken from Antergos Live Boot)

So what Ive tried so far is playing with Secure Boot enable/disable, UEFI enable/disable and legacy.

  • Booting with all these different settings I get

    error: file '/boot/grub/x86_64-efi/normal.mod' not found. Entering rescue mode... grub rescue> _

    Entering the boot options I got the usual stuff in Legacy boot (Removable Drive, Hard drive etc...) and in UEFI Boot I get lots of stuff I installed earlier but actually removed (elementaryOS, Fedora, ubuntu, and two times Windows Boot Manager). Most of these lead to a UEFI Boot screen with an old version of Arch Linux which does not work.

Since I don't have that much knowledge of (U)EFI/SecureBoot/GRUB/GPT/MBR/etc. I don't know what to do. I tried to repair via the boot repair disk, but that one somehow tries to restore elementaryOS instead of arch linux and also gives some kind of error ("Please enable a repository containing the [grub...] packages in the software sources of ArchLinux")

At best I want to be able to boot back into arch linux again but also be able to boot back into windows 8.

  • Are you sure the bootdisc order in the BIOS has not been swapped? I.e. do you remember the SDD always to be sdb? If it used to be sda it will not boot and starting it from a rescue disc probably gives you the file not found because grub is looking at the wrong device. I would look at changing that as the first measure. – Anthon Dec 3 '14 at 10:03
  • Unfortunately I can't remember if it was sda or sdb or maybe sdc. So the letters correspond to the boot order in BIOS? I took a look in the BIOS of my laptop but it seems I cannot configure the boot order of the harddrives. – Someguy Dec 3 '14 at 17:01
  • On older BIOSes you cannot change the boot order. On the other hand there is little change for a drive to get connected on a different cable in a laptop, unless you have the drives in hardware bays that are exchangeable. – Anthon Dec 3 '14 at 17:22
  • No the HDD and SDD are internal. What else can I do? Can't I just reinstall GRUB or something? – Someguy Dec 3 '14 at 17:27
  • Yes you can reinstall grub, but you have to make sure that both your /boot/grub/grub.cfg and /etc/fstab are corrected/updated as well. – Anthon Dec 3 '14 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.