2

I want to enable Russian keyboard layout on a Debian remote desktop (connected with Xvnc). dpkg-reconfigure keyboard-configuration changed /etc/default/keyboard as desired:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:ctrl_shift_toggle,grp:switch,grp_led:scroll"

BACKSPACE="guess"

Then

aromanov@ws:~/IdeaProjects/scalan$ sudo service keyboard-setup restart
[ ok ] Setting preliminary keymap...done.
aromanov@ws:~/IdeaProjects/scalan$ sudo udevadm trigger --subsystem-match=input --action=change # produces no output

The new layout doesn't show up in System Settings > Keyboard > Layout settings and Ctrl+Shift doesn't work. I've also tried setting it directly from the terminal:

aromanov@ws:~/IdeaProjects/scalan$ setxkbmap ru
XKB extension not present on :2

Googling doesn't give anything too useful, unfortunately. Can I fix this (e.g. by passing some arguments to Xvnc or changing ~/.vnc/xstartup)?

  • I know of no X server providing the VNC protocol which has the XKB extension. – AProgrammer Dec 3 '14 at 10:38
  • @AProgrammer Are there other remote desktop protocols which can provide it? – Alexey Romanov Dec 5 '14 at 10:22
  • The issue is not the VNC protocol, it is the implementation of Xvnc. I've not looked at this for years (that's why I didn't give an answer, I haven't done the minimal research to provide something more than an outdated recollection). – AProgrammer Dec 5 '14 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.