-4
#yum update
^[[3~Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use su                                                                                        bscription-manager to register.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dmidecode.x86_64 1:2.11-2.el6 will be updated
---> Package dmidecode.x86_64 1:2.12-0.1.el6.rfx will be an update
---> Package dstat.noarch 0:0.7.0-1.el6 will be updated
---> Package dstat.noarch 0:0.7.2-1.el6.rfx will be an update
---> Package iotop.noarch 0:0.3.2-7.el6 will be updated
---> Package iotop.noarch 0:0.6-1.el6.rfx will be an update
---> Package lzo.x86_64 0:2.03-3.1.el6 will be updated
---> Package lzo.x86_64 0:2.06-1.el6.rfx will be an update
---> Package mtr.x86_64 2:0.75-5.el6 will be updated
---> Package mtr.x86_64 2:0.84-1.el6.rfx will be an update
---> Package perl-CPANPLUS.x86_64 0:0.88-136.el6 will be updated
---> Package perl-CPANPLUS.noarch 0:0.9001-1.el6.test will be an update
---> Package perl-Compress-Zlib.x86_64 0:2.021-136.el6 will be obsoleted
--> Processing Dependency: perl-Compress-Zlib for package: perl-core-5.10.1-136.                                                                                        el6.x86_64
---> Package perl-DBD-SQLite.x86_64 0:1.27-3.el6 will be updated
---> Package perl-DBD-SQLite.x86_64 0:1.29-2.el6.rfx will be an update
---> Package perl-DBI.x86_64 0:1.609-4.el6 will be updated
---> Package perl-DBI.x86_64 0:1.622-1.el6.rfx will be an update
---> Package perl-HTML-Parser.x86_64 0:3.64-2.el6 will be updated
---> Package perl-HTML-Parser.x86_64 0:3.69-1.el6.rfx will be an update
---> Package perl-IO-Compress.noarch 0:2.052-1.el6.rfx will be obsoleting
--> Processing Dependency: perl(Compress::Raw::Zlib) = 2.052 for package: perl-I                                                                                        O-Compress-2.052-1.el6.rfx.noarch
---> Package perl-IO-Compress-Base.x86_64 0:2.021-136.el6 will be obsoleted
--> Processing Dependency: perl-IO-Compress-Base for package: perl-core-5.10.1-1                                                                                        36.el6.x86_64
---> Package perl-IO-Compress-Bzip2.x86_64 0:2.021-136.el6 will be obsoleted
--> Processing Dependency: perl-IO-Compress-Bzip2 for package: perl-core-5.10.1-                                                                                        136.el6.x86_64
---> Package perl-IO-Compress-Zlib.x86_64 0:2.021-136.el6 will be obsoleted
--> Processing Dependency: perl-IO-Compress-Zlib for package: perl-core-5.10.1-1                                                                                        36.el6.x86_64
---> Package perl-Log-Message-Simple.x86_64 0:0.04-136.el6 will be updated
---> Package perl-Log-Message-Simple.noarch 0:0.06-1.el6.rfx will be an update
---> Package perl-Module-Build.x86_64 1:0.3500-136.el6 will be updated
---> Package perl-Module-Build.noarch 1:0.3607-1.el6.rfx will be an update
---> Package perl-Module-CoreList.x86_64 0:2.18-136.el6 will be updated
---> Package perl-Module-CoreList.noarch 0:2.25-1.el6.rfx will be an update
---> Package perl-Term-UI.x86_64 0:0.20-136.el6 will be updated
---> Package perl-Term-UI.x86_64 0:0.26-1.el6.rfx will be an update
---> Package perl-Test-Harness.x86_64 0:3.17-136.el6 will be updated
---> Package perl-Test-Harness.noarch 0:3.23-1.el6.rfx will be an update
---> Package perl-Test-Simple.x86_64 0:0.92-136.el6 will be updated
---> Package perl-Test-Simple.noarch 0:0.98-1.el6.rfx will be an update
---> Package perl-Time-Piece.x86_64 0:1.15-136.el6 will be updated
---> Package perl-Time-Piece.x86_64 1:1.20-1.el6.rfx will be an update
---> Package perl-URI.noarch 0:1.40-2.el6 will be updated
---> Package perl-URI.noarch 0:1.60-1.el6.rfx will be an update
---> Package perl-XML-Parser.x86_64 0:2.36-7.el6 will be updated
---> Package perl-XML-Parser.x86_64 0:2.40-1.el6.rfx will be an update
---> Package perl-XML-Twig.noarch 0:3.34-1.el6 will be updated
---> Package perl-XML-Twig.noarch 0:3.37-1.el6.rfx will be an update
---> Package perl-libwww-perl.noarch 0:5.833-2.el6 will be updated
---> Package perl-libwww-perl.noarch 0:5.837-2.el6.rfx will be an update
---> Package portreserve.x86_64 0:0.0.4-9.el6 will be updated
---> Package portreserve.x86_64 0:0.0.5-2.el6.rfx will be an update
---> Package python-crypto.x86_64 0:2.0.1-22.el6 will be updated
---> Package python-crypto.x86_64 0:2.6.1-1.el6.rfx will be an update
---> Package python-netaddr.noarch 0:0.7.5-4.el6 will be updated
---> Package python-netaddr.noarch 0:0.7.10-1.el6.rfx will be an update
---> Package python-paramiko.noarch 0:1.7.5-2.1.el6 will be updated
---> Package python-paramiko.noarch 0:1.7.6-1.el6.rfx will be an update
---> Package rsync.x86_64 0:3.0.6-9.el6_4.1 will be updated
---> Package rsync.x86_64 0:3.1.1-1.el6.rfx will be an update
---> Package tcp_wrappers.x86_64 0:7.6-57.el6 will be updated
---> Package tcp_wrappers.x86_64 0:7.6-57.el6.test will be an update
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el6 will be updated
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el6.test will be an update
---> Package tcpdump.x86_64 14:4.0.0-3.20090921gitdf3cb4.2.el6 will be updated
---> Package tcpdump.x86_64 14:4.4.0-1.el6.rft will be an update
--> Finished Dependency Resolution
Error: Package: perl-core-5.10.1-136.el6.x86_64 (@anaconda-RedHatEnterpriseLinux                                                                                        -201311111358.x86_64/6.5)
           Requires: perl-IO-Compress-Base
           Removing: perl-IO-Compress-Base-2.021-136.el6.x86_64 (@anaconda-RedHa                                                                                        tEnterpriseLinux-201311111358.x86_64/6.5)
               perl-IO-Compress-Base = 2.021-136.el6
           Obsoleted By: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extra                                                                                        s)
               Not found
Error: Package: perl-core-5.10.1-136.el6.x86_64 (@anaconda-RedHatEnterpriseLinux                                                                                        -201311111358.x86_64/6.5)
           Requires: perl-Compress-Zlib
           Removing: perl-Compress-Zlib-2.021-136.el6.x86_64 (@anaconda-RedHatEn                                                                                        terpriseLinux-201311111358.x86_64/6.5)
               perl-Compress-Zlib = 2.021-136.el6
           Obsoleted By: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extra                                                                                        s)
               Not found
Error: Package: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extras)
           Requires: perl(Compress::Raw::Zlib) = 2.052
           Installed: 1:perl-Compress-Raw-Zlib-2.021-136.el6.x86_64 (@anaconda-R                                                                                        edHatEnterpriseLinux-201311111358.x86_64/6.5)
               perl(Compress::Raw::Zlib) = 2.021
           Available: perl-Compress-Raw-Zlib-2.030-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.030
           Available: perl-Compress-Raw-Zlib-2.033-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.033
           Available: perl-Compress-Raw-Zlib-2.034-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.034
           Available: perl-Compress-Raw-Zlib-2.035-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.035
           Available: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.037
           Available: perl-Compress-Raw-Zlib-2.051-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.051
           Available: perl-Compress-Raw-Zlib-2.052-1.el6.rfx.x86_64 (rpmforge-ex                                                                                        tras)
               perl(Compress::Raw::Zlib) = 2.052
Error: Package: perl-core-5.10.1-136.el6.x86_64 (@anaconda-RedHatEnterpriseLinux                                                                                        -201311111358.x86_64/6.5)
           Requires: perl-IO-Compress-Bzip2
           Removing: perl-IO-Compress-Bzip2-2.021-136.el6.x86_64 (@anaconda-RedH                                                                                        atEnterpriseLinux-201311111358.x86_64/6.5)
               perl-IO-Compress-Bzip2 = 2.021-136.el6
           Obsoleted By: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extra                                                                                        s)
               Not found
           Available: perl-IO-Compress-Bzip2-2.015-1.el6.rf.noarch (rpmforge)
               perl-IO-Compress-Bzip2 = 2.015-1.el6.rf
Error: Package: perl-core-5.10.1-136.el6.x86_64 (@anaconda-RedHatEnterpriseLinux                                                                                        -201311111358.x86_64/6.5)
           Requires: perl-IO-Compress-Zlib
           Removing: perl-IO-Compress-Zlib-2.021-136.el6.x86_64 (@anaconda-RedHa                                                                                        tEnterpriseLinux-201311111358.x86_64/6.5)
               perl-IO-Compress-Zlib = 2.021-136.el6
           Obsoleted By: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extra                                                                                        s)
               Not found
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
rpmforge-release-0.5.3-1.el6.rf.x86_64 is a duplicate with rpmforge-release-0.5.                                                                                        2-2.el5.rf.x86_64
2

Who ever is managing this box has done a pretty big no no. You're mixing YUM repositories that are offering the same packages.

Notice these lines, for example:

Error: Package: perl-core-5.10.1-136.el6.x86_64 (@anaconda-RedHatEnterpriseLinux                                                                                        -201311111358.x86_64/6.5)        
Error: Package: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extras)

The bit in those lines at the end, "@anaconda-RedHatEnterpriseLinux -201311111358.x86_64/6.5" and "rpmforge-extras" are 2 YUM repositories. From the looks of it they both contain packages which are in conflict with one another. There is really no easy way to fix an issue such as this. At least none that I've ever seen.

You typically have to yum remove X the offending packages, preferably from the 3rd party repository, "rpmforge-extras", for example. This is like performing surgery, and you'll need to take care when doing this, otherwise you can get your system into an even more hosed state.

  • RE: "Whoever is managing this box..." tbh I would blame the repo maintainers. Yeah the sysadmin could (and probably should) do some sort of protectbase but how hard is it to just rename your packages if they're the same as what's in the base channel? A sysadmin should be able to just use your repo without having to think about this stuff. – Bratchley May 17 '15 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.