2

I have just installed OpenSUSE 13.1 on a computer. After that, I did a zypper update and a reboot and the computer would not boot. The error message was something like "no bootable device found". I use grub2 with EFI Support as boot loader and I suppose that the error message means that grub cannot find the right partition. My partitions are setup like this. (What I actually did here was reinstalling OpenSUSE and then updated again. However, I have not yet turned of the computer when I get the following output)

computer-name:~ # fdisk -l
WARNING: fdisk GPT support is currently new, and therefore in an experimental phase. Use at your own discretion.

Disk /dev/sda: 240.1 GB, 240057409536 bytes, 468862128 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt


#         Start          End    Size  Type            Name
1         2048       321535    156M  EFI System      primary
2       321536      4530175      2G  Microsoft basic primary
3      4530176     46475263     20G  EFI System      primary
4     46475264    468860927  201.4G  Microsoft basic primary
computer-name:~ # df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/sda3       20510716 4407320  15038440  23% /
devtmpfs         8182632      40   8182592   1% /dev
tmpfs            8195504      80   8195424   1% /dev/shm
tmpfs            8195504    6980   8188524   1% /run
tmpfs            8195504       0   8195504   0% /sys/fs/cgroup
tmpfs            8195504    6980   8188524   1% /var/lock
tmpfs            8195504    6980   8188524   1% /var/run
/dev/sda1         159564     128    159436   1% /boot/efi

I know that there are plenty of questions that are similar to this one, for example this but I find no question that I think really fits my particular issue, that I can understand. Does anyone know how to fix this issue (preferably at the current state before rebooting, but any working solution would be gladly accepted)?

8
  • Have you tried grub2-mkconfig -o /boot/grub2/grub.cfg?
    – eyoung100
    Dec 2, 2014 at 15:50
  • Just like that? With nothing else? Should I do it before or after I reboot?
    – patrik
    Dec 2, 2014 at 15:51
  • @eyoung100 Ok I tried that, but it did not work. However, when I now entered the rescue mode, I could not find the file. /boot/grub2/ was empty. Should I try to create a file grub.cfg by running grub2-mkconfig -o /boot/grub2/grub.cfg once more?
    – patrik
    Dec 2, 2014 at 16:07
  • @eyoung100 however, I must add that looking into the grub shell, I see find the file under (hd0,2).
    – patrik
    Dec 2, 2014 at 16:15
  • You should not create that by hand. Read this ActiveDoc The default has changed.
    – eyoung100
    Dec 2, 2014 at 16:36

1 Answer 1

2

In the end it seemed to be a compatibility problem with the BIOS. I updated the BIOS and after that all went through just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .