0

I recently built my own computer, and I was excited to finally get to the installation of the operating system. I chose Fedora 20 to use as my primary operating system, and I was able to successfully install the system as I wished without running into any major issues.

I started with an updated ISO from October 27th that I downloaded from the link in the Fedora IRC channel topic (here). One of the first things I ended up doing was updating the system with sudo yum update, which there were about 80 different packages that needed updating. The kernel version that was included with my ISO was a 3.16 variant, and the update installed the latest 3.17 kernel update available for Fedora 20. I successfully updated and rebooted my machine.

Upon reaching the kernel selection screen, it automatically booted into the latest kernel, and it was here that I first noticed the issue. Immediately after the kernel option was selected, it very quickly popped up with some sort of error message (I think something about TCI check failing?) and then proceeded to a blank, black screen. My only option at this point was to power off and power back on.

Just in case it may have been a random error, I did try rebooting a few times and kept getting the same results. I then tried going back to the original kernel version installed with my system, and it immediately prompted me for my hard drive decryption phrase. After entering the phrase, I was successfully able to log back into my system.

Additionally, I have also tried booting into runlevel 3 or multi-user mode in systemd, and even that ended up with the same result as before. I manually edited the kernel boot parameters and added systemd.unit=multi-user.target, and even with that parameter, there was no change in my results, limiting my ability to further diagnose the issue.

Is there something added in the latest kernel that might have an incompatibility with my system? Or is there a place where I can check the full system log? I'm not an expert with Linux, but I do know how to navigate the system via command line, so if you need more information, please just ask for it and tell me where to find it! Thanks.

  • Have you checked to see if it has mounted the filesystem and logged anything during the failed boots? – goldilocks Dec 2 '14 at 15:06
  • @goldilocks: How and where can I check for that information? – Justin W. Flory Dec 2 '14 at 15:08
  • 1
    Try the bad kernel, then reboot with the good one and see if there's anything in /var/log/messages or /var/log/syslog (I'm not sure what the default setup with fedora is there, you may have to poke around) with a timestamp (text, in the file) that corresponds to that boot. It probably didn't, if the whole filesystem is encrypted and you never entered a password. If not there's not much you can do to even report a bug on the kernel, although you could try starting with the fedora package. – goldilocks Dec 2 '14 at 15:13
  • @goldilocks: I just applied the latest kernel update, 3.17.4, and something weird happened. Upon trying to boot into the latest kernel, I received the same black screen as always from my monitor. For laughs, I tried typing my decryption phrase — and seconds later, my login screen appeared! However, I wouldn't call this working. The resolution of the screen is completely miserable, and it is improperly sized on my monitor. Everything is extremely blurry as well. Additionally, during bootup, I noticed this flashed on my screen: Fast TSC calibration failed – Justin W. Flory Dec 2 '14 at 21:44
  • @goldilocks: Additionally, I think the information you are needing would be documented in journalctl -ax, but I don't know how to get that into an easily readable text file or paste site... I will work on getting that. Also also, I just noticed that in the GNOME Settings, the display is now registered as "Unknown", whereas before on 3.16, it recognized it as a Samsung monitor. – Justin W. Flory Dec 2 '14 at 21:47
1

As it turns out, it seems the underlying issue was not having the right proprietary drivers installed for my nVidia graphics card. I was under the presumption that I had to use nVidia's driver installer, but installing the right packages from RPMFusion and disabling Nouveau worked perfectly. Since installing the necessary drivers, my system is running significantly smoother, and it also eliminated this annoying magenta line that was on the far left end of my monitor.

I followed a guide from if-not-true-then-false.com, which can be found here. I installed the drivers and then re-enabled Plymouth as per the instructions in the guide. This fixed 100% of my issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.