17

I have a USB bluetooth dongle:

root@maiko-cce-lin:~# lsusb | grep Bluetooth
Bus 001 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

It rarely works, and when I do get it to work it stops working when I reboot.

It isn't software blocked:

root@maiko-cce-lin:~# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

My device is recognized by hciconfig

root@maiko-cce-lin:~# hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
    BD Address: 00:1F:81:00:01:1C  ACL MTU: 1021:4  SCO MTU: 180:1
    DOWN 
    RX bytes:330 acl:0 sco:0 events:8 errors:0
    TX bytes:24 acl:0 sco:0 commands:30 errors:22
    Features: 0xff 0x3e 0x09 0x76 0x80 0x01 0x00 0x80
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    Link policy: 
    Link mode: SLAVE ACCEPT 

but I can't turn on my hci interface:

root@maiko-cce-lin:~# hciconfig hci up
Can't init device hci0: Connection timed out (110)

I don't understand why; the hcitool command doesn't show any devices:

root@maiko-cce-lin:~# hcitool dev
Devices:

I've tried to restart my bluetooth service too with this command (and then repeated all the previous commands again) but it didn't work:

root@maiko-cce-lin:~# service bluetooth restart
 * Stopping bluetooth                                                    [ OK ] 
 * Starting bluetooth                                                    [ OK ] 
root@maiko-cce-lin:~# 

What could be wrong?

2
3

What you describe looks like this reported bug.

1
  • it looks similar but I'm not sure.
    – MaikoID
    Aug 8 '11 at 13:55
1

FWIW I just had these same symptoms with the same model dongle. However, it seemed to resolve immediately when I moved the dongle from a USB hub to a direct USB port on the computer. If you're having the same problem then maybe try that.

My symptoms in detail:

Each time the dongle was plugged in I got entries in /var/log/syslog like this:

Sep  7 10:05:20 gus-workstation bluetoothd[18537]: Listening for HCI events on hci0
Sep  7 10:05:20 gus-workstation NetworkManager[837]: <warn> bluez error  getting default adapter: No such adapter
Sep  7 10:05:30 gus-workstation bluetoothd[18538]: Can't init device hci0: Connection timed out (110)

Mine also showed in hciconfig & no amount of restarts or replugs made a difference.

Also weirdly, I can't reproduce the problem now that the dongle has been paired to something (if I put it back in the hub port now, it now works fine.)

Hth.

2
  • I'm not using a USB hub =| but thx for the answer.
    – MaikoID
    Sep 8 '11 at 0:45
  • OK, one more! The "no hub" fix didn't keep working for me, it stopped working as soon as I power cycled the machine. However, I was previously running Ubuntu Maverick (bluez 4.69.) Did a dist-upgrade to Natty (kernel 2.6.38-11, bluez 4.91) and now it works fine. :/
    – projectgus
    Sep 17 '11 at 0:56
1

Do the following and it will be fixed.

rfkill block bluetooth

then

rfkill unblock bluetooth
rfkill unblock bluetooth

Afterwards check to see if it is running using

hciconfig

It works every time for me

1
  • Can this be traced using syslogs? Where are they located? I see the device moving from DOWN to DOWN INIT RUNNING, but then seems to fail and reverts to DOWN with no other information
    – jocull
    Oct 8 '19 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.