2

After struggling with USB 3.0 on creating a Live USB version Kali, I've finally managed to actually boot it up and then use the apt-get update + upgrade + dist-upgrade successfully.

But here comes another problem for me, after I've finished the updates and upgrades I decided to reboot my system. After choosing the Kali with Encrypted Persistence at the Kali Boot Menu the system boots up where it shows lines of information like starting kernel, etc.

But after the last line of command which is Starting Service: GDM3 all that I get was a black screen with a moveable mouse pointer that looked like an eye. It should be showing the kali Dragon background image and loads the desktop but instead... just a black screen, if I run it on AMD64 FailSafe Mode, the desktop screen shows up, normal.

I've tried restarting the GDM3, dkpg-reconfigure GDM3 & Reboot, but all to no avail (Haven't tried reinstalling the GDM3 though as I haven't any internet connection at the moment).

Could anyone please shed some light on this? What should I check? or What should I do?

UPDATES:

I've looked at the X.0.log located at /var/log... I don't see any errors except for a couple of Warning. Pic provided below.

X.0.log with Warning!

  • Did you find the solution?? – Arjun Hegde Aug 15 '16 at 7:26
3

The logs are your friends. Use this key combination when you see the black screen with the cursor:

Ctrl + Alt + F2

you should see the prompt, login with root credentials.

go to /var/log and do:

less Xorg.0.log

Start reading the log to know what's going on with Xorg.

From what i read can be a problem of your ~.xinitrc file, but difficult to be sure without checking the logs.

Good luck friend.

  • I've tried checking the log as you suggested, but I saw no error on it... just some warning about non-existent folder. I'll post the picture in a minute. – Realmz Dec 2 '14 at 5:29
-2

Type gdm3, then hit the Alt+PrintScreen keys. It will load screen after few minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.