0

I need to install gstreamer1.0 libraries.. I found that they are in wheezy-backports. So I added wheezy-backports to sources.list updated try ton install and stuck on dependency problems:

aptitude install gstreamer1.0-libav
The following NEW packages will be installed:
  gstreamer1.0-libav{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 166 kB of archives. After unpacking 353 kB will be used.
The following packages have unmet dependencies:
 gstreamer1.0-libav : Depends: libavcodec54 (>= 6:9.1-1) which is a virtual package. or
                               libavcodec-extra-54 (>= 6:9.13) which is a virtual package.
                      Depends: libavformat54 (>= 6:9.1-1) which is a virtual package.
                      Depends: libavutil52 (>= 6:9.1-1) which is a virtual package.
                      Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.2) but it is not going to be installed.
                      Depends: libgstreamer1.0-0 (>= 1.2.0) but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     gstreamer1.0-libav [Not Installed]                 



Accept this solution? [Y/n/q/?] n

*** No more solutions available ***

To install libavcodec54 is really impossible - its only in sid I dont know why. When I try to add sid repository I end up again in other dependency problems (with libavutil52)

Then I added testing jessie repository and install from there.. it somehow works, but I have problems loading some plugin:

gst-inspect-1.0 --version

(gst-plugin-scanner:16077): GStreamer-WARNING **: Failed to load plugin '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmpeg2dec.so': /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmpeg2dec.so: undefined symbol: mpeg2_guess_aspect
gst-inspect-1.0 version 1.4.4
GStreamer 1.4.4

This error is show just once, when I run again it shows no error..

I know that gstreamer 1.0 is currently unstable .. but is there any correct way how to install it into debian 7 wheezy?

0

Ok I found something on forum of debian: http://forums.debian.net/viewtopic.php?f=6&t=118530&p=558557&hilit=how+install+gstreamer1.0#p558557 Its about that two developers made some changes and the result is that you cannot install gstreamer1.0-libav

Workaround is to use this repository, but I am not happy with it. http://www.deb-multimedia.org/ You have to use also wheezy-backports from that repository because of libavutil52 library which is only there..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.