14

My ubuntu has just crashed. Now that I restarted it, it does nothing when I enter my password. The screen just gets refreshed leaving the password space empty again. However, if I try to enter a wrong password, it recognize that it is an invalid password. There is also a weird white box around the user names and password in the ubuntu log in page.

A worth mentioning point is that while I was using Ctrl+Alt+Del to restart the computer the window that asks whether I want to restart or shut down the computer was not able to show the characters, there were blank squares instead of each character.

I have tried to set a new password for my user by logging into recovery shell, but it did not work! I also created a new user but couldn't log in to that neither:(

Any suggestion how I can fix it?

1 Answer 1

12

Press Ctrl+Alt+F3 and login into the shell using your username and your password. In this case username will be your username you set when you installed Ubuntu.

Now run ls -lah. If in the output the line(and look for the line that ends with .Xauthority)

-rw-------  1 root root   53 Nov 29 10:19 .Xauthority

then you need to do chown username:username .Xauthority and try logging in.

Else, do ls -ld /tmp. Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt.

drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Else, you need to do sudo chmod a+wt /tmp and check again.

If not both, I'd recommend you either
Make sure you are connected to internet with DHCP on.

  1. sudo apt-get purge lightdm
  2. sudo apt-get update
  3. sudo apt-get install lightdm
  4. dpkg-reconfigure lightdm

Now type sudo shutdown -r now to restart.

5
  • 1
    What helped me is to do the same change to .ICEauthority as one for .Xauthority. That is, chown username:username .ICEauthority Commented Feb 7, 2020 at 19:07
  • And what do I do if nothing of these are working? I am trying to install Ubuntu on a separate SSD
    – Pavlos
    Commented Mar 24, 2020 at 23:06
  • @Pavlos try chat or IRC channel
    – Alex Jones
    Commented May 8, 2020 at 13:29
  • @EdwardTorvalds Thank you! I formatted my disk and install Windows and then Ubuntu to fix it!
    – Pavlos
    Commented May 12, 2020 at 13:50
  • 1
    On Ubuntu 20, this basic process worked but with gdm3 instead of lightdm.
    – dysbulic
    Commented Sep 16, 2020 at 23:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .