4

I set an eth1 interface in Linux Debian, and I rebooted after that, but I don't see it when I would like to use the sudo ifconfig, or ifconfig command (as root) only the eth0 interface. The settings is the following:

enter image description here

And after the configuration and rebooting I see that:

enter image description here

Why I can't see the eth1 interface? Or if I would like to use the DHCP in a network, to set static ip address on server computer is neccessary?

5
  • I made a mistake: I deleted a 'k' character end of the 'loopbac', but I corrected it. But I continue can't see the eth1. – blackcornail Nov 28 '14 at 23:09
  • Did you created/configured the virtual device in virtualbox? – Braiam Nov 28 '14 at 23:22
  • I set a NAT and Internal interfaces under the network option, and I put in a virtual disk. Not more. – blackcornail Nov 28 '14 at 23:31
  • There is only one NIC which the system calls eth0, and you want it to be called eth1? – Hauke Laging Nov 29 '14 at 4:48
  • No. I would like to two interfaces: 'eht0' and 'eth1' (and the 'lo' of course). – blackcornail Nov 29 '14 at 9:00
3

There is a typo in your config:

auto eht1

It should be instead:

auto eth1

So the interface just is not autoenabled. You can still see it with

ifconfig eth1

and bring it up with

ifconfig eth1 up
1

Sometimes if you reboot your computer, the computer don't see the new settings of interfaces. (I don't know why.) But if you "reboot" the eth1 with ifdown eth1 and after that ifup eth1 you will see the new settings.

1
  • In my case, I used the command, "reboot", of the computer in the Terminal Window to solve the problem. Now, the computer shows as output the interface after using the "ifconfig" command. – masarapmabuhay Jul 21 '20 at 1:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.