I'm trying to use the TL-WN725N as an USB WiFi-Adapter with Fedora 20.

I followed these insructions and the adapter worked fine and even survived two updates during the last few weeks.

Then I did a yum update today, and it still worked fine until I restarted my computer. I tried to reload the module and got insmod: ERROR: could not insert module 8188eu.ko: Invalid module format.

What I found out was, that my kernel and the kernel-headers in the module are not the same anymore and that I had to update the kernel, so I did that and got

sudo yum install kernel-headers
Loaded plugins: langpacks, refresh-packagekit
Package kernel-headers-3.17.3-200.fc20.x86_64 already installed and latest version
Nothing to do

Now I am a bit puzzeld about how to get the module to load properly. Anyone got any idea?


Your module was built for an earlier kernel (the one that has just been updated).

Make sure that you've rebooted so that you are using the latest kernel.

Confirm that the running kernel and the installed version of kernel-headers is the same.

You'll now need to recompile your module again for the current kernel:

cd rtl8188eu
make clean
make all
make install
modprobe -r 8188eu
modprobe 8188eu

Unfortunately, you'll have to keep doing this every time you update the kernel until that driver makes it into the mainstream kernel package.

There is a facility called Dynamic Kernel Module Support that can automatically build out-of-tree modules such as yours every time the kernel is updated (VirtualBox drivers use it, for example) but it will involve a fair amount of additional work to configure. You may find that it's more effort than it's worth.

This is the downside of living on the bleeding edge of technology ;-)

| improve this answer | |
  • I redid the steps from make all to loading the module, but I still get the same error, so recompiling again doesn't seem to do the job? – Merlin Nov 28 '14 at 22:30
  • Eh...no... I'll try that then. – Merlin Nov 29 '14 at 13:15
  • @Merlin - glad it works. I've edited the answer to clarify. – garethTheRed Nov 29 '14 at 13:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.