0

How do I automatically log a user in using Cubian? I have tried removing the default users password but it still promotes to enter a username at the login screen.

I've tried editing the /etc/inittab to the following but with no success:

1:2345:respawn:/bin/login -f cubie tty1 </dev/tty1 >/dev/tty1 2>&1
1

I don't know Cubian, but i'm using Slim (so as Cubian as i read in the official site) to autologin Arch (in my mame cabinet).

I'm using the default_user option (i didn't get it if you don't want to use that) but to make it work I also needed to configure .xinitrc in the default_user homedir.

From my slim.conf configuration:

login_cmd           exec /bin/bash -login ~/.xinitrc %session

[...]

# default user, leave blank or remove this line
# for avoid pre-loading the username.
default_user        charlie

[...]

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
auto_login          yes

And my .xinitrc:

#!/bin/sh

[...]

exec xmonad&
exec wahcade

In your case I presume would be:

#!/bin/sh
exec mate-session

I hope i understood your question. Comment me something if I'm mistaken or something is unclear.

0

Marcs is right. I just tried based on these instructions: https://github.com/cubieplayer/Cubian/issues/323

The only difference from what Marcs said was the default user for Cubian was Simone. Just change that to cubie in addition to setting auto_login yes :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.