I'm trying to copy directory from local drive to remote server with -r parameter, however I'm getting:

scp: System error: 1633648 (Failed to retrieve error string (err:317))

This is the syntax I use:

scp -i ~/.ssh/id_rsa -r temp username@remoteserver:/%username%/ext

Yes, I'm using identity file, so that it wouldn't prompt me for password. Anybody knows why am I getting the error?

  • 1
    Try to run scp with -v and see if you can pinpoint the error... – Rmano Nov 26 '14 at 20:30
  • 1
    Have you already tried to ssh to that server first using that key file to see if the problem is not related to authentication ? – VaTo Nov 26 '14 at 21:08
  • I just spoke with net admin and I was told the remote server does not allow directory. Thanks anyway! – MMichael Nov 27 '14 at 18:44

With rcp, and scp use the -r option to recursively copy a directory and all it's contents (including other directories). With cp use -R.

scp -r programming myName@orca.st.usm.edu:

Just worked fine for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.