16

A similar question got asked but got closed.

If you install Debian 7.7 to a USB in Windows with unetbootin and then try to install Debian from that USB, it will complain that it 'cannot mount CDROM' and the install will not go any further.

1
  • 8
    Just unplug the USB stick and then plug it again. Now try to detect CD-ROM again. It works! Oct 23 '16 at 0:44
8

You can mount manually in a shell window (Ctrl + Fnumber)

mount -t vfat /dev/sdb /cdrom

But, the option of warsong works fine. It seems like a UNetBootin-Win bug u_u

1
  • if you are using installer over ssh (putty or similar) you need to use <Ctrl> + A then choose 1-4 to select shell (screen commands)
    – Thesane
    Jun 29 '21 at 22:03
7

I got the same error message when booting from a second partition of my usb stick. Zorbax' solution helps here too, however you need to choose the correct partition. For my case it was

mount -t vfat /dev/sdb2 /cdrom
2
  • I had to use the command without the parameter -t, mount /dev/sdb1 /cdrom
    – spacebiker
    Nov 6 '19 at 18:44
  • I had to use mount -t vfat /dev/sdb1 /cdrom Apr 19 '20 at 8:08
2

Acccording to Debian-faq

This might be a little problem on older versions of Windows, as many Windows image-burning programs use their own formats for CD images.

And Wiki-ubuntu

Win32DiskImager is particularly good for pre-release testing and new releases, when the standard tools like Unetbootin might not be ready

Maybe there are an issue with unetbootin on some windows distro . You can use an alternative like : win32diskimager or Refus recommaded by Ubuntu , or ImgBurn ...

2

In order to install Debian 9.5.0 on the bare metal, I had to enable IOMMU on my motherboard BIOS (for the keyboard and mouse to work). After that, I put Debian DVD 1 ISO into my pendrive with Rufus tool using "dd" mode. To make the graphical installer read the packages from my pendrive as if it were a CD-ROM, I had to plug the pendrive into a USB 2.0 port available at my machine's front panel. And to finish up installation, I said "no" to "force UEFI" option.

(I haven't experienced bare metal install issues with Windows over USB 3, though)

Good luck!

1

The way around this problem is to rename the Debian .iso file to a .img file, and then to write the image to the USB with Win32DiskImager (I used 0.9.5 and it worked fine). The install will then work.

0

For QEMU (if a switch like "-cdrom installer.iso" is used):

mount /dev/vdb2 /cdrom

Not the answer you're looking for? Browse other questions tagged or ask your own question.