5

I installed Ubuntu 14.04 on my new Lenovo G50-70. The wifi works perfectly in windows, however it behaves strangely on Ubuntu. It is slow, doesn't load heavier sites at all, and after a while, completely drops.

After some research I discovered: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1320070

sudo rmmod rtl8723be && sudo modprobe rtl8723be does not change anything, the wifi remains gone.

The first thing I tried was sudo make install the driver from this repo: https://github.com/lwfinger/rtlwifi_new. Unfortunately nothing changed.

Next I tried to disable the sleep feature: echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf, without any luck.

I then tried: sudo rmmod -v ideapad_laptop But removing that module did not help either.

Here is some environment info:

uname -a
Linux zirconcode 3.13.0-40-generic #69-Ubuntu SMP Thu Nov 13 17:53:56 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lsusb | grep Rea
Bus 002 Device 006: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 002 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller

lsmod | grep rtl
rtl8723be             139336  0 
btcoexist             183378  1 rtl8723be
rtl_pci                39740  1 rtl8723be
rtlwifi               121008  3 btcoexist,rtl_pci,rtl8723be
mac80211              626557  3 rtl_pci,rtlwifi,rtl8723be
cfg80211              484040  2 mac80211,rtlwifi

I am stuck as none of the solutions seem to work. Any ideas would be much appreciated.

  • Switching form the 3.13 to the 3.16 kernel and reinstalling the new drivers seems to have done the trick. Will post as answer if it holds. – ZirconCode Nov 26 '14 at 9:35
  • 1
    I am sadly having the same problem, tried everything but the connection still drops, well the rate has decreased significantly by updating the driver driver but its still present, i also disabled the sleep feature by echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf your second post seems to be written 2 hours later from your first post, is it working flawlessly or have you bumped into problems again ? The drivers for this wlan card seems to be horrid. It would be very much appreciated if you can confirm. – Akash Pal Jan 3 '15 at 15:13
  • @Akash Everything's been running flawlessly since then. The drivers are indeed horrible, Realtek isn't being supportive at all. Is your kernel 3.16 or newer? – ZirconCode Jan 3 '15 at 18:39
4

Upgrading my kernel from 3.13 to 3.16 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/) and reinstalling the new driver from https://github.com/lwfinger/rtlwifi_new seems to have solved my problems. Don't forget to reboot.

Note: Upgrading the kernel in itself did not help.

protected by Community Jan 12 '15 at 15:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.