4

i am able to generate uefi iso using

mkisofs -quiet -R -J -T -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -e images/efiboot.img -no-emul-boot -c isolinux/boot.cat -b isolinux/isolinux.bin -o UEFI.iso .

and following command confirms it as EFI media

dumpet -i UEFI.iso

Validation Entry:
    Header Indicator: 0x01 (Validation Entry)
    PlatformId: 0x00 (80x86)
    ID: ""
    Checksum: 0x55aa
    Key bytes: 0x55aa
Boot Catalog Default Entry:
    Entry is bootable
    Boot Media emulation type: no emulation
    Media load segment: 0x07c0
    System type: 0 (0x00)
    Load Sectors: 4 (0x0004)
    Load LBA: 227 (0x000000e3)
Section Header Entry:
    Header Indicator: 0x91 (Final Section Header Entry)
    PlatformId: 0xef (EFI)
    Section Entries: 1
    ID: ""
Boot Catalog Section Entry:
    Entry is bootable
    Boot Media emulation type: no emulation
    Media load address: 0 (0x0000)
    System type: 0 (0x00)
    Load Sectors: 744 (0x02e8)
    Load LBA: 239 (0x000000ef)

But when selecting this iso as boot media it just doesn't boot

Contents of UEFI.iso

ls /mnt/EFI/BOOT/

BOOTX64.conf  BOOTX64.efi  splash.xpm.gz  TRANS.TBL

ls /mnt/images

efiboot.img  efidisk.img  install.img  product.img  pxeboot  TRANS.TBL

Any idea what can be the issue.Regular redhat 6.5 iso boots on this uefi server

  • 1
    You needn't bother with an .iso file if your target is UEFI - UEFI requires a partition structure which .iso does not support. The hybrid images that you'll usually find in the wild today are very bad compromises and usually loop mount an efi compatible image just to get going. - if they get going at all. All you need is a bootable sqsh on an esp - it is simply done, more efficient, and far less of a headache. Or even just an initramfs that mounts an NFS root, for that matter. – mikeserv Nov 26 '14 at 8:07
  • thanks @mikeserv somehow it worked but it ignores isolinux.cfg and instead uses BOOTX64.conf hence not able to auto install using kickstart. – Kevin Parker Nov 27 '14 at 7:40
  • if you mean the iso file worked - it will work as the others do - by loopmounting another image. The iso is ancillary - and ignored. Within a hybrid iso's efi boot image you'll find the kernel and initramfs that it actually loads. What you need to do is to loopmount that file and see what it does - there will only be a couple of files within. Elsewhere in the iso file there will be a 64-bit squash image that it mounts as root after that. Pretty much all you need are the initramfs, kernel and root image. – mikeserv Nov 27 '14 at 8:07
  • If the prob. is in the bootloader, did you got a kernel panic? Your iso looks correct, maybe the problem is the bootloader that you are using: grub2, elilo, or what? The file images/efiboot.img is a disk image (vfat), try to mount it on linux, inside you will find another bootx64.efi and sometimes another cfg file, A common problem is that you edit the cfg file in the ISO but not the cfg inside the disk image. Another common problem with grub2 is that you can put the cfg inside of boox64.efi (GRUB2 bootloader) and it's not possible to change it. Check if BIOS has a secure boot. – Dany Flores Jul 21 '15 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.