13

I'm having issues connecting my Logitech K810 Bluetooth keyboard in Debian Jessie with BlueZ version 5.23-1, kernel 3.16.0-4.

The keyboard works fine most of the time but sometimes it doesn't work at all and bluetoothctl gives me the error that the controller is unavailable.

When this occurs, hciconfig still recognizes the device and I get this output:

# hciconfig hci0 up 
# hciconfig
hci0:   Type: BR/EDR  Bus: USB
    BD Address: 40:2C:F4:68:02:CA  ACL MTU: 1021:8  SCO MTU: 64:1
    UP RUNNING PSCAN 
    RX bytes:21820 acl:1132 sco:0 events:68 errors:0
    TX bytes:1182 acl:11 sco:0 commands:53 errors:0

But no devices are shown in the bluetoothctl prompt and it gives me this output:

[bluetooth]# power on
No default controller available
[bluetooth]# scan on
No default controller available

Rebooting or sometimes suspending/resuming fixes the issue: bluetoothctl will again recognize both the controller and the keyboard which works again.

Bluetooth is consistently hard and soft unblocked according to rfkill.

The relevant output from lspci -v, I guess would be this:

03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
        Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at f0400000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi

I didn't have this problem with the same hardware in Debian Wheezy.

What could it be the bluetooth controller to be unavailable at times?

  • I have the same problem in OSMC running in Raspberry Pi. Did you find a solution? Share it if you have one, please. – user2109718 Jun 19 '15 at 0:21
  • No, haven't found a solution ... – MajorBriggs Jun 27 '15 at 8:39
  • I have encountered the same issue with OSMC on a Raspberry Pi. The keyboard shows up when scanning with hcitool. Bluetoothctl commands result in 'No default controller available'. – Dallas Aug 30 '15 at 15:10
  • 1
    After coming across this question during my investigations several times now: There still seems to be no answer, however, sometimes removing (modprobe -r btusb) and adding (modprobe btusb) the kernel module helps to get the controller back (so you can avoid doing a full reboot). – Marcus May 22 '17 at 14:39
  • @Dallas see my answer. You just need to run it as sudo and it works fine. – jamescampbell Dec 14 '18 at 2:35
2

I believe the answer is simply to run bluetoothctl with sudo.

Thus, sudo bluetoothctl. Then every command works fine power on, agent on etc. with no errors.

Confirmed working on Raspian Stretch.

0

Is kernel update an option?

Have you tried the latest linux-firmware package?

Also you can try the suggestions in secion "About iwldvm support and known issues" in here https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

0

Maybe try systemctl start hciuart

  • Welcome on the Unix SE! I suggest to explain, what you are doing and why. – peterh Aug 1 '18 at 18:34
-1

First enable bluetooth manually with the GUI. this is how it worked for me. i know this post is old, but it worked for me. Just search in your main menu for "bluetooth" (On my current mint 18 sarah it is like that)

You can then come back and try the commands with "power off"

  • 1
    What GUI? What exact steps? How would powering it off help establish a connection? – Jeff Schaller Feb 10 '17 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.