2

Im working with an 'odroid' fanless PC. The latest OS attempt on it is the stock Ubuntu 14.04 that comes with it. Have made some progress getting the networking (eth0) started but am having issues with the wireless.

Per dmesg I see this:

[    7.504855] usbcore: registered new interface driver rtl8192cu
[    7.570063] systemd-udevd[386]: renamed network interface wlan0 to wlan2
[    8.430903] IPv6: ADDRCONF(NETDEV_UP): wlan2: link is not ready

But via ipconfig wlan2 I'm seeing this:

wlan2 Link encap:Ethernet  HWaddr <mac addr>
      inet addr:192.168.70.1  Bcast:192.168.70.255  Mask:255.255.255.0
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

In /etc/network/interfaces.d/wlan I have this:

auto wlan2
iface wlan2 inet static
address 192.168.70.1
netmask 255.255.255.0

The ultimate goal is to turn it into an access point using dnsmasq and (probably) hostapd. I disabled network-manager as it was trying too hard to 'help me' and kept undoing what I was working on.

Starting hostapd I get this message:

Configuration file: ./hostapd.conf
nl80211 driver initialization failed.
hostapd_free_hapd_data: Interface wlan2 wasn't started

Seeing this I tried the instructions listed here. No change in status.

I know the adapter works as a WAP as I was able to get it working (mostly) using Debian. Further this command iwconfig wlan0 mode master works ok. Following this with iw list I get nothing back.

So clearly the WAP antenna / dongle isn't configured properly. I've never worked with Ubuntu before so I'm sure I've gone astray somewhere. Suggestions on where to look?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.