0

I have a laptop with small screen resolution, and when I connect external monitor before boot, it keeps resolution of the laptop screen, until I log in.

I'm using LXDM.

How to fix it?

1

Turns out it's because the screen "copies" the laptop screen - apparently both are enabled, even though one is closed under the lid.

In my case, the fix was easy:

edit /etc/lxdm/LoginReady and add a xrandr line you want:

In my case:

FILE: /etc/lxdm/LoginReady

#!/bin/sh
xrandr --output VGA1 --mode 1920x1080 --rate 60.00 --same-as LVDS1 --output LVDS1 --off

You can obtain this line using lxrandr, when you "save settings", it writes it into ~/.config/autostart/lxrandr-autostart.desktop.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.