1

I have a Dell Inspiron 15 model 5547 with a AMD Radeon HD R7 M265. With a clean installation of Arch Linux (I've tried installing Debian too, without success.) I tried installing the open-source drivers, but I've got the no screens found error. Now I tried installing the proprietary drivers (and the "hybrid Intel/AMD graphics card" section of the wiki too). I already have the module fglrx loading, an Xorg config from aticonfig --initial

But when I run fglrxinfo it says Error: unable to open display (null)

My lspci output:

VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265]
  • Just now I installed this driver wiki.archlinux.org/index.php/Intel_graphics And it worked! But I want to know if this is right... – Marcelo Gimenes Nov 25 '14 at 9:41
  • Hi, I was wondering if you had any luck getting the r7 m265 to work under Arch? My laptop is exactly same as yours and I am also using it with the intel drivers currently. I have been searching for a while now to get the open source drivers to work but it seems support for r7 m265 hasn't come yet. Also a lot of confusion regarding the names. According to AMD's site, the proprietary drivers should work. But I have been unsuccessful in getting it to run using Vi0l0's repo (plus, that supports only X server 1.15 and I am currently using 1.16)... Any help/info would be much appreciated... – fijas Dec 3 '14 at 17:38
  • I opened a post in the Arch Linux Forum, you can check it out :) bbs.archlinux.org/viewtopic.php?id=190236 – Marcelo Gimenes Dec 4 '14 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.