1

I have a VM using ubuntu 14.04. running on a windows. If I use the terminal on the VM desktop, I can connect to my servers without passwords using registered SSH Keys.

When I connect to the VM from my windows using a ssh client, I cannot log in the server without password.

Linux(VM) ---> Server                     |  Authentication with SSH keys works

SSH session ---> Linux(VM) ---> Server    | Ask for the server password.

How can it use the SSH key registered in the VM when I am remotely connected?

0

Not sure which client you are using, but for some the default settings is to forward SSH agent requests and to ignore the middle-man's key(s). Look in your documentation to disable "agent forwarding", in ssh(1) that is the -a option and the ForwardAgent configuration value.

1
  • I tried with Putty and SmarTTY. Looking into that. – Syl Nov 24 '14 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.