0

So this is something really strange that happened. I've been using mostly urxvt and I want 256 color support, so I installed urxvt256c. However, urxvt256c doesn't listen to .Xresources, it stays default settings. My .Xresources looks like this:

! urxvt*background:#20202E
urxvt*background: #2D3233
urxvt*foreground: #f0f0f0
urxvt*cursorColor: #f0f0f0
urxvt.scrollBar: false
urxvt.internalBorder: 6
urxvt.geometry: 91x22

!BLK
urxvt*color0:               #495052
urxvt*color8:               #495052

!RED
urxvt*color1:               #D2738A
urxvt*color9:                #D2738A

!GRN
urxvt*color2:               #C1B492
urxvt*color10:              #C1B492

!YEL
urxvt*color3:               #819E7C
urxvt*color11:              #819E7C

!BLE
urxvt*color4:               #A78B92
urxvt*color12:              #A78B92

!MAG
urxvt*color5:               #8B99B5
urxvt*color13:              #8B99B5

!CYN
urxvt*color6:               #D2738A
urxvt*color14:              #D2738A

!WHT
urxvt*color7:               #DCDCDC
urxvt*color15:              #DCDCDC

!urxvt*borderLess: true
urxvt*font: xft:Monospace:bold:pixelsize=11.5
urxvt*boldFont: xft:Monospace:pixelsize=11.5
urxvt.letterSpace:-1
Xft.dpi:96
Xft.antialias:1
Xft.hinting:1
Xft.hintstyle:hintslight
Xft.autohint: false
Xft.rgba:rgb
Xft.lcdfilter:lcddefault

! clickable urls
URxvt.perl-ext-common: default,matcher
URxvt.url-launcher:    /usr/bin/firefox
URxvt.matcher.button:  1

Any way to make urxvt256c inherit the .Xresources?

2
  • Maybe urxvt256c is using a different instance name? Do the URxvt settings take effect? Nov 23, 2014 at 21:39
  • @Gilles Aha! Changing urxvt to urxvt256c fixed it. Stupid of me, should've thought of that.
    – user92582
    Nov 23, 2014 at 22:37

2 Answers 2

0

The configuration made in .Xresources does not affect urxvt immediately. These settings need to be reloaded for any new instance to apply them. You may use xrdb to do so:

xrdb -load ~/.Xresources
1
  • Hi, I've done this and with the same result. It stays default.
    – user92582
    Nov 23, 2014 at 21:08
0

Changing urxvt to urxvt256c fixed it!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .