5

For example, I've application (game) that has only 640x480 resolution. Now I've 2 options: launch it in window-mode, and will has 640x480 size or enable fullscreen and will fill all screen.

What I want is to resize application without going fullscreen (e.g. to 1024x768).

As for now I've tried 2 solutions:

  1. Enable 'Emulate a virtual desktop' in winecfg. At first it will launch desktop with that resolution, but when I enable fullscreen in application it will shrink that desktop to 640x480.

  2. Start Wine in inner X-server:

    Xephyr -ac -br -noreset -screen 1024x768 :1.0 &
    ZEPHYR_PID=$!
    sleep 1
    DISPLAY=:1.0 wine game.exe
    kill $ZEPHYR_PID
    

    Same problem here, it will resize window when I enable fullscreen.

4
  • 1
    Care to share which game exactly, so others can try to reproduce?
    – doktor5000
    Nov 27, 2014 at 16:28
  • @doktor5000, it doesn't work with all games that I've tried. E.g. Touhou Project (from 6 to 14.3), Bunny Must Die, Planetarian. As a downloadable example here is Cave Story (win-version): cavestory.org/download/cave-story.php
    – anlar
    Nov 27, 2014 at 18:39
  • 1
    It seems you cannot force this. If the game resizes the window by itself, this is not related to the Xephyr screen size you provided. You would have to change this application behaviour within windows/wine. I've also tried with askubuntu.com/a/16761/329633 and e.g. wine explorer /desktop=CS,1366x768 "Doukutsu.exe" works pretty good, although the game will switch to 640x480 by itself. For others way to do something similar see wiki.winehq.org/256ColorMode and tfischernet.wordpress.com/2009/02/14/… . Shall I write an answer?
    – doktor5000
    Nov 27, 2014 at 20:36
  • I've tried solution with vnc. It works (vnc-viewer displays window in extended resolution), but it's slow - kinda hard to play that way.
    – anlar
    Nov 29, 2014 at 17:11

1 Answer 1

1

i ever play in fullscreen , i make my scripts for change the resolution & refresh rate of my monitor , because i use the wrong rate , in my monitor appear a floating box with a msg "Entrace not adm" . for fix that i use something like the follow

This its with "Ace Of Spades"

#!/bin/bash

# Resolution Fix
echo `xrandr --current | grep current | awk '{print $8}'` >> /tmp/width
echo `xrandr --current | grep current | awk '{print $10}'` >> /tmp/height
cat /tmp/height | sed -i 's/,//g' /tmp/height
WIDTH=$(cat /tmp/width)
HEIGHT=$(cat /tmp/height)
rm /tmp/height /tmp/height
echo "$WIDTH"x"$HEIGHT" >> /tmp/Resolution
Resolution=$(cat /tmp/Resolution)
rm /tmp/Resolution
# Resolution Fix

BINARY="$HOME/.wine/drive_c/Ace of Spades/client.exe"
$(wine "$BINARY" -"$@" "%u") &
xrandr -s 800x600 -r 77

sleep 2
BINARYPID=$(pidof $BINARY)
taskset -p 0xFFFFFFFF $BINARYPID &

while Launchers=$(pidof "client.exe")
    do   
        sleep 1
    done
    xrandr -s $Resolution -r 63
exit 0

In Resume this script its for launch Ace Of Spade , from the "mimetype" and the servers from web-browser for the protocol "aos://" that's its another type of configuration , i not explain here.

This launch the game , after the game its launched , the resolution of monitor are change to 800x600 until i close the game , when i close the game , my resolution are restored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.