1

When I first turn on the computer the mouse works as usual, but shortly after that the mouse cursor will stop moving and will stay stuck in one spot on the screen. This is hard to describe but although the picture of the cursor is stuck in one spot on the screen the position of the mouse seems to continue to update. So if I move the mouse around I'll see hyperlinks and buttons highlight to indicate that the mouse is moving over them. I can also click and the button or hyperlink activates as usual. The image of the cursor is stuck in one spot but it changes from pointer to cursor to text selection as I move the mouse around.

I've tried to reset the mouse but the behavior stays the same.

sudo rmmod psmouse
sudo modprobe psmouse

This behavior happened with Xubuntu 12.04 and I installed Linux Mint 17 and see the same behavior. I have a wireless Logitech mouse. I tried plugging in a wired mouse and see the same behavior.

Any suggestions? I'm not even sure what to search for!

Thanks!

  • This could be a bug in the video driver messing up the composition of the mouse pointer onto the windows (I've seen stranger bugs). If you click, is the effect consistent with the mouse position that you expect (e.g. push the mouse to a corner)? Does it work with more recent distribution or with another video driver (e.g. nvidia instead of nouveau or vice versa)? – Gilles Nov 23 '14 at 19:52
1

Your cursor problem seems to be the constant while distros change, indicating that it may be a hardware problem. Attempt disabling drawing the cursor via hardware and then restart the X server. This may be done by editing your xorg.conf which is often located in /etx/X11/xorg.conf. Note that it may be also be split into several files under /etc/X11/xorg.conf.d - see the xorg.conf(5) man page for more details.

  1. find

    Section: "Device"
    

    which refers to the configuration of graphic your adapter.

  2. before the end of the section, add the following:

    Option "HWCursor" "off"
    

    (or change it appropriately, if already present)

  3. restart Xorg; this can be done in a number of ways:

    • log out and in
    • go into a virtual terminal and kill it, e.g. killall Xorg (usually has to be done with root privileges) - the X server should be respawned after being killed
    • restart your computer

Source: http://www.pendrivelinux.com/mouse-pointer-disappears-after-switching-users/

  • Thanks! Linux Mint has the extra step of creating an xorg.conf to edit, but this solved the problem! – Frankenstein Nov 24 '14 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.