0

I'm running Debian 6.0.7 (Squeeze). Normally, to get the euro symbol, I would type altgr-$ and this works fine on Ubuntu but with Squeeze when I hit those keys the cursor jumps back to the beginning of the previously typed word.

Can anyone tell me what needs setting up correctly.

Also, I'm running an application that needs to use the euro symbol and in a MySQL database that the app uses the euro symbol has been replaced by this: €.

Edit:
Output from stty -a:

speed 38400 baud; rows 35; columns 145; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z;
rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

For what it's worth, if I type a Euro symbol on my local OS and try to copy/paste it into the Debian terminal, the same thing happens as if I tried to type the character. Also, some numbers in combination with alt gr clear the command-line prefix temporarily and replace it with (arg: n) where n is some number. alt gr + 7 gives me { and alt gr + 8 gives me [.

migrated from serverfault.com Nov 22 '14 at 7:51

This question came from our site for system and network administrators.

1

I can't speak for the UI, but for mysql, you need to set the database charset encoding when you create the db and the client charset encoding when you are inserting data into the db. You may want to check what keyboard map you're using for x11.

Additionally, you may want to change the locale settings on your debian squeeze machine to use UTF-8

eg:

export LANG=en_GB.UTF-8
  • I'm actually running Ubuntu locally, and the character appears fine for that, but it's when I ssh on to Debian Squeeze that it doesn't work. Also, if I ssh onto another Ubuntu box, the character works fine on that too. The character won't display properly if I try to type it on the command line outside of MySQL, so I don't think it's a specific issue with MySQL. I've also set the default charset for MySQL to UTF-8. – RTF Nov 19 '14 at 16:55
  • Did you try setting the terminal encoding on the remote machine? – Andrew Domaszek Nov 19 '14 at 16:59
  • I tried setting that env variable, no luck unfortunately, exactly the same. – RTF Nov 19 '14 at 17:46
  • We're now in Super User territory, but please update your question with the output from stty -a on squeeze. Might need to stty iutf8. It shouldn't fix your application encoding, but might fix your terminal problem. – Andrew Domaszek Nov 19 '14 at 17:57
  • I didn't know which site to post on, so I posted on both (although the SuperUser post hasn't attracted any attention). Question is updated. – RTF Nov 19 '14 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.