2

so that it appears in Thunar's sidebar under the name 'Schijf-2'?

I am running linux mint13 xfce and this has been a headache causer for the last couple of days. the UUID of this partition is:

this is the output from blkid:

/dev/sda2: UUID="913aedd1-9c06-46fa-a26e-32bf5ef0a150" TYPE="ext4"

How should I enter this in fstab so that it mounts to this directory: /media/Schijf-2/

I have tried so many things, I have read so many stackexchange questions, but I still have not succeeded.

Edit: without an entry in fstab, the drive is shown as Schijf-2 in the file manager now.

But this partition is not automatically mounted at startup. Which causes links to be not working, Dropbox asking for a new location etc.

And to have this automatically mounted, I need an entry in fstab. Right?

Or is there an other place where I can set to mount it automatically at startup/login?

edit 2:

After adding it again to fstab as @jasonwryan suggested, the partition shows up in Thunar when I am logged in into my own account. After logging in into my dad's account, it does not show up. Which again confirms my thoughts that somehow my dad's account has got messed up.

Which files or directory from my account should I copy paste to my dad's account to have the same settings as my own account?

I already tried removing my dad's account and adding again, but that got me into totally different trouble. (but this is a different question and has nothing to do with mounting my /dev/sda2 in fstab).

2

By default, if your fstab entry is:

UUID=913aedd1...    /media/Schijf-2   ext4    rw,relatime   0    2

your partition will not be shown as Schijf-2 in your sidebar, unless it is labelled Schijf-2. You have two options:

  • Leave the fstab entry as is and label your partition (e.g. if sda2 is your partition):

    e2label /dev/sda2 Schijf-2

  • Leave the partition as is and add x-gvfs-name=Schijf-21 to your mount options in fstab:

    UUID=913aedd1 /media/Schijf-2 ext4 rw,relatime,x-gvfs-name=Schijf-2 0 2


1 this works even if the partition has a different label and you want it to be shown as Schijf-2

  • I do not really understand your last sentence. Do you mean that, because sda2 is on my first disk (sda2) I do not even need to add sda2 to fstab? – DutchArjo Nov 21 '14 at 21:59
  • Thank you. I appreciate all your help! I have now added the partition in fstab as @jasonwryan suggested, considering everything you and gareththered suggested. – DutchArjo Nov 26 '14 at 20:43
2
UUID=913aedd1-9c06-46fa-a26e-32bf5ef0a150    /media/Schijf-2   ext4    rw,relatime,discard   0    2

See man fstab for the complete list and description of the options.

1

You need to add a label to the partition. To do this, either use a filesystem specific tool, such as e2label for ext2/3/4 or use gparted.

For example:

#e2label /dev/sda2 Schijf-2

Do NOT mount the partition on a mount point (such as /home/Schijf-2) as it will then be part of that directory tree in your file manager and consequently will not show up.

The label will then display in the left hand column of most file-managers, including Thunar and Gnome Files.

If you mount these partitions in /etc/fstab then they effectively become part of the larger filesystem tree, which begins at the top-level root (/). Unlike Windows, where you have partitions show up as drive letters (C:, D: etc) it doesn't make sense to have them show up as separate devices in Unix/Linux as they all sit somewhere under root, when mounted. Many systems have seperate partitions for /home, /usr, '/tmp', 'var' etc and there wouldn't be any point in showing them as 'Devices'.

The 'Devices' list shows partitions that aren't mounted as part of the filesystem tree - such as partitions containing alternative distros in a dual/multi boot system, or USB-sticks and the like.

I believe you can add locations to the 'Places' list though. View->Sidepane-Shortcut (although I'm not in front of thunar at the moment to confirm). This would allow you quick access from your file-manager.

  • I have labeled both my partitions, none of them is showing up in thunar. The only mention I have overthere is 'filesystem'. Nothing more, nothing less. Did I mess up the system so that nothing is working how it should be (no partition labels shown, relocating dirs not working etc etc) or is mint 13 xfce a pain in the ass? Thunar is showing the cdrom drive, so it is not that Thunar is not showing any devices at all. – DutchArjo Nov 21 '14 at 21:53
  • I'm starting to doubt my answer now! What happens if you remove the entries from /etc/fstab (or comment them out) and unmount them? Do they show up? That's how mine is currently working. – garethTheRed Nov 21 '14 at 22:02
  • Yes, removing the entry from fstab was all I needed to do, after adding a Label to the partition. It is shown now as "Schijf-2". Question solved. But now Have 1 problem: I can only accept one answer... – DutchArjo Nov 22 '14 at 7:26
  • I've edited my answer to reflect this. There can only be one correct answer - one will be more correct than the other :-) Pick what is the best answer in your opinion and up-vote the other correct ones. – garethTheRed Nov 22 '14 at 7:31
  • @DutchArjo - I've edited my answer to reflect the edits in your question. – garethTheRed Nov 24 '14 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.