1

I just recently migrated to Wheezy from Arch, everything has gone very well except I can't seem to get multiple monitors to work. Here is my setup:

machine: Dell Latitude E6540 laptop

graphics:

00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
Subsystem: Dell Device 05be
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at f5800000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features

When I set up multimonitor on arch I used xrandr, but using that now gives me odd output, namely it doesn't even detect the other monitor

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080       0.0*
   1280x1024       0.0 
   1024x768        0.0 
   800x600         0.0 
   640x480         0.0 

Any thoughts on what the issue could be? I am assuming it is either driver or kernel related because the hardware should be able to support this functionality.

NOTE: Also posted on debian forums(http://www.debianuserforums.org/viewtopic.php?f=55&t=3115)

3 Answers 3

1

It's a common Debian problem, you could try the following:

  1. Edit /etc/apt/sources.list
  2. Comment out all sources from /etc/apt/sources.list
  3. Add the following to /etc/apt/sources.list : "deb http://ftp.debian.org/debian wheezy-backports main"
  4. save, exit your editor
  5. from the command line "apt-get update"
  6. launch synaptic package manager
  7. search for and install the latest kernel image from bpo. For me, at this time, it was "linux-image-3.14-0.bpo.2-amd64" (not the RT version)
  8. exit
  9. Edit /etc/apt/sources.list
  10. Un-do commenting out from above step 3.
  11. save, exit your editor
  12. From the command line "apt-get update"

If you would have problems with the resolution of the 2nd screen, I sugest following the steps of my own question: unlisted screen resolution (intel)

7
  • What effects would installing a new kernel have on my system? (Sorry, not super familiar with this process) Nov 21, 2014 at 16:45
  • It is a driver problem, driver modules come with the kernel. You will not have any other (unwanted) effects doing this.
    – switch87
    Nov 21, 2014 at 16:47
  • In the boot loader you can always choose to boot using the old kernel you are using now if the new one would crash the system.
    – switch87
    Nov 21, 2014 at 16:48
  • awesome, thanks so much for your help. I will post back here with results soon. Nov 21, 2014 at 16:52
  • This worked perfectly, thanks. The displays are mirrored now though, and the in the system settings -> Displays window the monitors are still not detected. Thoughts? Nov 21, 2014 at 17:04
0

If you are getting the mirrored monitors and you are using Intel:

You need version 2:2.20.14-1 of xserver-xorg-video-intel available here: http://snapshot.debian.org/package/xserver-xorg-video-intel/2%3A2.20.14-1/

Thanks to http://forums.debian.net/viewtopic.php?f=6&t=106650 for the answer.

Reboot, and then xrandr will detect both screens.

0

I have a similar problem with my installation. I have a Lenovo Y50 laptop, using Debian 8 without problems in general (when I start with 2 monitors the main start in dark and I can't increase the brightness until I login). However at some point I started to have an odd behaviour, beside the original problem. The first thing I noticed was the system won't recognize the second monitor when I plug it, I have to restart the computer to use it. If I'm using the second monitor when I unplug it the system don't notice the change and I get an extended screen but just one monitor. Again I have to reboot.

Other problem I noticed was with the trackpad... I had a trackpad options in the configuration panel and suddenly they dissappear and the option I had activated stop working. Also I started to notice inestability in the system; when I was working (I use a lot of windows apps under virtualbox) the system just restart the X11.

So, Those are my problems, I don't know if you have the same issues, but I found a solution that maybe works for you guys.

Trying to solve the problem with the brightness at some point I tried to change the GDM2 with lightdm and it solves all of the problems except the brightness one. So as far as I understand somebody breaks somehting in GDM2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .