More than failed it was a partial update, when I was updating there was a power failure and my laptop shutdown (battery is broken). Now when I try switching my system on, it shows the chameleon and then it just shows a small cursor at the top left of the screen and stays there forever. Any help to recover?

  • tried running run level 3, worked, did a zypper update, it gave me a bunch of programs that wont be installed and said nothing to do. Any solution please? – Aadi Droid Jul 19 '11 at 8:08

Just a thought:

  • insert installation CD in the drive
  • reboot
  • start installation
  • at the second stage, when the hardware is initialized go to console
  • mount your harddisk
  • mount CD
  • cp -av /your_cd_mount_point /your_harddrive/INSTALLCD
  • when done, eject CD, reboot
  • run system in runlevel 3
  • rpm -qa --last > installed_recently_rpms
  • go to repositories management
  • disable all repositories
  • add local repo from HDD (the one you just installed)
  • accept, run software managemet
  • find all packages which were recently updated (see point above), choose "update unconditionally"
  • accept
  • wait and pray
  • reboot

Good luck!

| improve this answer | |
  • guess what, i tried a lot of solutions, nothing worked. Re installed suse, still same problem !!!! now what ? – Aadi Droid Jul 24 '11 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.