-2

I am trying to download VLC for use on my Scientific Linux. After going to the vlc-2.0.6 folder, I ran "./configure" and got error messages

configure: error: Could not find libmad on your system: you may get it from http://www.underbit.com/products/mad/. Alternatively you can use     --disable-mad to disable the mad plugin.

I went to that link and downloaded madplay, libmad, libid3tag, and was able to configure all of them with no problems. However, when I go back to the vlc folder and run "./configure", I still get the same error.

I heard one solution may be to use sudo-apt. But when I try that I get the error

sudo: apt-get: command not found

What else can I do?

1

apt-get is for debian-based distros, yours is based on red hat and has yum for software management. you should just do sudo yum install vlc and it will download and install vlc and all of its dependency's for you.

P.S.: read trough this faq for understending how to work with your linux distro, it is for Fedora users, but most of it should be the same for SL

  • when I tried that, I got the message saying "Sorry, user csx is not allowed to execute '/usr/bin/yum install vlc' as root" – csx Nov 20 '14 at 2:13
  • Than you did not do the sudo part. – switch87 Nov 20 '14 at 10:57
  • Could you please mark this as answered? – switch87 Nov 21 '14 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.