1

I was trying to install Corosync and Cman using

yum install -y pacemaker cman pcs ccs resource-agents 

This works fine on CentOS 6.3. Tried the same on Red Hat Enterprise Linux Server 6.6 and ran into issues. It gives an error like:

Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager 
There was an error communicating with RHN. 
RHN Satellite or RHN Classic support will be disabled. 

Error Message: 
        Please run rhn_register as root on this client 
Error Class Code: 9 
Error Class Info: Invalid System Credentials. 
Explanation: 
     An error has occurred while processing your request. If this problem 
     persists please enter a bug report at bugzilla.redhat.com. 
     If you choose to submit the bug report, please be sure to include 
     details of what you were trying to do when this error occurred and 
     details on how to reproduce this problem. 

Setting up Install Process 
No package pacemaker available. 
No package cman available. 
No package pcs available. 
No package ccs available. 
Nothing to do 

/etc/yum.repos.d/centos.repo is as follows:

[centos-6-base] 
name=CentOS-$releasever - Base 
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
enabled=0 
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/

Realized that this Red Hat version does not have the High Availability add-on package. This package needs to be bought OR the version needs to be upgraded to 7. I got information like Pacemaker has been available as part of RHEL, since 6.0 as part of the High Availability (HA) add-on.

Question:

  1. Is the above understanding correct?

  2. Are there significant differences in the manner Corosync and CMan are configured on Enterprise Server vs. CentOS?

  • Take a look at using docker instead. It's trivially easy to pull down images for corosync, pacemaker, etc. and run them on CentOS. – slm Nov 19 '14 at 18:40
1

The output suggests your machine is not properly registered with RHN. It won't be able to install any package from Red Hat without.

But yes, additionally you will need the HA subscription to be able to install pacemaker and friends.

There are no difference between thr RHEL and the CentOS packages (besides here not relevant Red Hat logos). It's just the support, access.redhat.com and all the other RH goodies that you miss.

1

I use RHEL 6.9 so I'm not sure if it's similar enough for 6.6 so I'm going to go out on a limb and assume (oh no) but if you have the install media, and if it comes with the HighAvailability software in a HighAvailability directory, you can just create a repo from the media and install from there rather than the internet. I work on standalone systems often without internet so I have to do this frequently.

Just in case you're not familiar, here are the steps at least that my system would use:
Mount the disc: mount /dev/sr0 /media
Create a local repo: vi /etc/yum.repos.d/local.repo
Inside the local.repo file, add this:
[localrepo]
name=baserepo
baseurl=file:///media/HighAvailability
gpgcheck=0
The name in the brackets [ ] and the name do not matter. This will create a local repo installing packages from the disk so once you unmount and eject the disk, you can't install unless you reinsert the disk.

Again, this is assuming 6.6 is similar to 6.9.

0

You must have the centos.repo as below, according to http://clusterlabs.org/quickstart-redhat.html

[ALL] # cat < /etc/yum.repo.d/centos.repo [centos-6-base] name=CentOS-$releasever - Base mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os #baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ enabled=1 EOF

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.