0

So I can load the program through the terminal by running the application as

sh /path/to/folder/bin/program

but when I'm trying to make a selectable icon through KDE Menu Editor I get the splash icon for the program but it doesn't load. I can't figure out why this is happening.

I even tried writing a script that runs the program and having KDE Menu Editor point to this script instead as

/path/to/script

and that doesn't work either. I'm extremely lost. I just get the splash screen and the bouncing icon, and then it hangs.

Why will it run fine through the terminal and not through kde?

FIXED Program was MATLAB and the solution was to use an environment

env -u _JAVA_OPTIONS /home/steven/MATLAB/bin/matlab -desktop -nosplash

7
  • Can you check using ps if your program is indeed launched or not?
    – Stark07
    Nov 19, 2014 at 6:04
  • ps shows it when I launch through the terminal, but not through kde. Same with top. Nov 19, 2014 at 6:32
  • Can you check if your application shows up in ksystemlog ?
    – Stark07
    Nov 19, 2014 at 7:29
  • Besides that that crashes (don't feel like bothering with fixing it), would this show anything different than ps and top mid launching? I can't see it in ps or top even while the splash screen is showing. Nov 19, 2014 at 7:40
  • 1
    It was MATLAB. I forgot that I solved this. Thanks for reminding me. I'll mark it as solved Feb 10, 2015 at 10:17

1 Answer 1

1

Solution was to use the environment option

env -u _JAVA_OPTIONS /home/steven/MATLAB/bin/matlab -desktop -nosplash

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .