0

Im using Arch and NetworkManager to handle my connection.

I can connect fine at boot but randomly at some point inevitable point it will just stop. NetworkManager shows I am still connected but Firefox, VPN, ping no longer work.

I have a bigger problem but I am looking atleast for a temporary solution. As it stands, I have to reboot and it seems to be my only option.

The only available commands I know of are:

ifup mlan0

and

ip link set mlan0 up

The first is not available on my distro and the second doesn't help.

Are there any other possibile commands I can try? At least to save me from rebooting everytime it stops.


*-network
description: Wireless interface
physical id: 2
bus info: firewire@1
logical name: mlan0
serial: 28:18:78:35:90:55
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=usb ip=192.168.1.11 multicast=yes wireless=IEEE 802.11abgn


Bus 003 Device 004: ID 1286:2044 Marvell Semiconductor, Inc.

Maybe this is the problem? Not sure, this is referencing Linux 3.11 but my kernel is 3.17. Still testing. https://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.11.1

Module: mwiflex

6
  • Have you tried restarting networking? Have you tried removing and reloading the driver module? There is a good QA here on working which kernel driver you are using which can then be removed with (as root) modprobe -r <module name> and then loaded with modprobe <module name>. The network service should be stopped first. Commented Nov 18, 2014 at 8:30
  • @garethTheRed - Not sure exactly what this means but I have restarted NetworkManager, as in disconnect and reconnect to my access point. This doesn't solve it. Its odd that NetworkManager will have full bars whether I have actual internet or not. No experience with removing/reloading modules. This is essentially the only problem (and quite an annoying one) with Arch. I am looking through your link now to get aquainted. Thanks.
    – David
    Commented Nov 18, 2014 at 16:01
  • @garethTheRed - I've concluded that this isnt the issue. (not to be overly complicated) My Arch is plain install on a mSATA USB. I've plugged it in 2 machines and it does this. Neither of the Host machines with 3 natively installed OS (Windows 7/Ubuntu and Windows 8) it is specifically just Arch.
    – David
    Commented Nov 18, 2014 at 16:26
  • Can we assume that it works fine if you connect an Ethernet cable instead of using WiFi? If so, then it's more than likely the driver for your USB WiFi adapter, in which case you'll need to work out what the chipset is - lsusb will show you the vendor and device IDs for the device. Commented Nov 18, 2014 at 16:43
  • @garethTheRed Not sure, I havent seen an ethernet cable in ages. :) My gut is saying its a module driver problem. I'm seeing a lot of instances of this around the web since you've mentioned it.
    – David
    Commented Nov 18, 2014 at 17:06

1 Answer 1

0

Just remove network-manager daemon service running on boot up process

$ sudo update-rc.d network-manager remove

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .