1

I want to install a package called plasma-nm (kde-nm-connection-editor) on Elementary OS Luna. But the problem is that software requires network-manager 0.9.8 or greater. while I have 0.9.7, can I upgrade network-manager? I mean if I manually download deb package it asks for many unmet dependencies, also some dependencies also requires new version.
Ubuntu, on the other hand, has 0.9.8 version. Since elementary OS is based on Ubuntu, why its out-dated ?

1

The reason why it's outdated is because latest ElementaryOS (Luna) is based on Ubuntu 12.04 LTS. It's an issue with the fixed release schedule Ubuntu have taken and which ElementaryOS is based upon. It's 3 years old in other words. I would recommend against trying to upgrade it. Instead install the latest version of ElementaryOS (Freya) which is based on Ubuntu 14.04 LTS.

  • why didnt Luna got updates? lack of funding or community developers ? – Edward Torvalds Apr 25 '15 at 12:01
  • 1
    The LTS releases do not get everything back ported. That is why they make newer releases. If they back ported everything it wouldn't be a LTS. – AlMehdi Apr 25 '15 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.